Subject: Re: Where can I find the doxyfile?

From: Bogdan Mart <[email-masked]>
Date: Fri, 6 Oct 2023 22:50:25 +0300

On 2008-06-02 18:33:42 Stefan Kaltenbrunner wrote:
>
> Zdenek Kotala wrote:
> > Xin Wang napsal(a):
> >> Hi,
> >> I don't know where I can find the doxyfile which generate
> >> "doxygen.postgresql.org" web site. I found that when reading code the
> >> doxygen source code is quite helpful. However, I want to generate an
> >> off-line copy of doxygen docs myself, but I can't find the doxyfile in
> >> the lastest source release.
> >
> > I think it is good idea. Stefan, what's about put it on the wiki?
>
> don't think the wiki is a good place (we would have to maintain it in
> addition to the main file) so I simply added a link on
> http:/doxygen.postgresql.org that contains the current copy of the
> configuration file that was used to generate a particular set of docs.
> However some of the things there are specific to our install so a bit
> (like some of the paths) of manual change will be required anyway.

Hello, sorry for resurrecting this old discussion, and necroposting,
but this was relevant.

It turns out that way back in 2008 it was possible to download Doxyfile
from https://doxygen.postgresql.org/ , which can be seen at:
https://web.archive.org/web/20080915132924/https://doxygen.postgresql.org/

I was able to download this Doxyfile from the web archive, and it actually
worked for me, after I changed the path to postgres sources and removed
header template. It even produced same result as on current web-site.

It would be nice if this doxygen file would be placed somewhere
on the current site.

P.S. I've tried to run doxygen on postgres sources without config,
and it didn't find any source file, this archived thread helped.

Perhaps doxygen file can be just placed into postgres git repository?

Best regards,
Bohdan Mart.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 6 Oct 2023 17:06:15 -0400

> Perhaps doxygen file can be just placed into postgres git repository?

We do link to a Doxygen build from our website:

	https://www.postgresql.org/developer/coding/

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: [email-masked]
Date: Sat, 7 Oct 2023 00:16:54 +0300

> 	https://www.postgresql.org/developer/coding/

Yes, there is link to deployed documentation generated by Doxygen
(unless I'm missing something), but I am talking about config file
for Doxygen to generate same documentation locally. 
There are no entries on Wiki regarding doxygen,
and not in build instructions. 

I was able to locate needed config file in Web Archive:
https://web.archive.org/web/20081210081808if_/http://doxygen.postgresql.org:80/pgsql.conf

But it would be nice if it was readily available if anybody other would like
to build docs locally.

---

From: <[email-masked]>
Date: Fri, 6 Oct 2023 14:44:05 -0700

Sometime earlier, I created a filter to annotate regular C comments as doxy comments. 
I'll attach it along with a sample doxyfile for running it.  Just in case it looks useful.

I've never been a big fan of Doxygen, but it seems to have gotten better over time.
Now that some editors are displaying doxygen comments on hover, I'm beginning to appreciate it.

d