Subject: Re: Refactoring of compression options in pg_basebackup

From: Alvaro Herrera <[email-masked]>
Date: Wed, 19 Jan 2022 12:50:44 -0300

On 2022-Jan-19, Michael Paquier wrote:

> +	printf(_("  -Z, --compress=[{gzip,none}[:LEVEL] or [LEVEL]\n"
> +			 "                         compress tar output with given compression method or level\n"));

Note there is an extra [ before the {gzip bit.

-- 
Álvaro Herrera         PostgreSQL Developer  —  https://www.EnterpriseDB.com/
"I suspect most samba developers are already technically insane...
Of course, since many of them are Australians, you can't tell." (L. Torvalds)

---

From: Michael Paquier <[email-masked]>
Date: Thu, 20 Jan 2022 14:32:43 +0900

> Note there is an extra [ before the {gzip bit.

Thanks!
--
Michael