Subject: Re: Add TLI number to name of files generated by pg_waldump --save-fullpage

From: David Christensen <[email-masked]>
Date: Tue, 27 Jun 2023 11:53:10 -0500

On Tue, Jun 27, 2023 at 1:12 AM Michael Paquier <[email-masked]> wrote:
>
> Hi all,
> (Fujii-san and David in CC.)
>
> Fujii-san has reported on Twitter that we had better add the TLI
> number to what pg_waldump --save-fullpage generates for the file names
> of the blocks, as it could be possible that we overwrite some blocks.
> This information can be added thanks to ws_tli, that tracks the TLI of
> the opened segment.
>
> Attached is a patch to fix this issue, adding an open item assigned to
> me.  The file format is documented in the TAP test and the docs, the
> two only places that would need a refresh.
>
> Thoughts or comments?

Patch looks good, but agreed that that comment should also be fixed.

Thanks!

David

---

From: Michael Paquier <[email-masked]>
Date: Wed, 28 Jun 2023 08:29:19 +0900

> Patch looks good, but agreed that that comment should also be fixed.

Okay, thanks for checking!
--
Michael