Subject: Re: Reducing the log spam

From: Jim Jones <[email-masked]>
Date: Tue, 5 Mar 2024 14:55:21 +0100

Hi Laurenz

On 05.03.24 13:55, Laurenz Albe wrote:
> Inspired by feedback to [1], I thought about how to reduce log spam.
>
> My experience from the field is that a lot of log spam looks like
>
>    database/table/... "xy" does not exist
>    duplicate key value violates unique constraint "xy"
>
> So what about a parameter "log_suppress_sqlstates" that suppresses
> logging ERROR and FATAL messages with the enumerated SQL states?
>
> My idea for a default setting would be something like
>
>    log_suppress_sqlstates = '23505,3D000,3F000,42601,42704,42883,42P01'
>
> but that's of course bikeshedding territory.
>
> Yours,
> Laurenz Albe
>
>
>
>   [1]: https://postgr.es/m/b8b8502915e50f44deb111bc0b43a99e2733e117.camel%40cybertec.at

I like this idea, and I could see myself using it a lot in some projects.

Additionally, it would be nice to also have the possibility suppress a 
whole class instead of single SQL states, e.g.

log_suppress_sqlstates = 'class_08' to suppress these all at once:

08000 	connection_exception
08003 	connection_does_not_exist
08006 	connection_failure
08001 	sqlclient_unable_to_establish_sqlconnection
08004 	sqlserver_rejected_establishment_of_sqlconnection
08007 	transaction_resolution_unknown
08P01 	protocol_violation

Best regards,
Jim

---

From: Pavel Stehule <[email-masked]>
Date: Tue, 5 Mar 2024 14:57:05 +0100

Hi

út 5. 3. 2024 v 14:55 odesílatel Jim Jones <[email-masked]>
napsal:

> >   [1]:
> https://postgr.es/m/b8b8502915e50f44deb111bc0b43a99e2733e117.camel%40cybertec.at
>
It can take code from PLpgSQL.

Regards

Pavel