Subject: Re: Improve documentation regarding custom settings, placeholders, and the administrative functions

From: Zhang Mingli <[email-masked]>
Date: Thu, 6 Feb 2025 23:03:50 +0800

On Feb 6, 2025 at 10:49 +0800, David G. Johnston <[email-masked]>, wrote:
>
> Yes, and when it does it is doing so in lieu of an error, and thus it is not returning the value of the setting.  It does not mean the value taken on by the named parameter is NULL, which is not possible. i.e., SHOW will never produce NULL.
Hi,

OK, LGTM.

--
Zhang Mingli
HashData

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 27 Feb 2025 11:26:37 -0700

On Thu, Feb 6, 2025 at 8:04 AM Zhang Mingli <[email-masked]> wrote:

> Yes, and when it does it is doing so in lieu of an error, and thus it is
> not returning the value of the setting.  It does not mean the value taken
> on by the named parameter is NULL, which is not possible. i.e., SHOW will
> never produce NULL.
>
> Hi,
>
> OK, LGTM.
>
>
Thank you for the review.  If you would like to add yourself as the
reviewer and mark this ready to commit here is the commitfest entry.

https://commitfest.postgresql.org/patch/5548/

David J.

---

From: Zhang Mingli <[email-masked]>
Date: Fri, 28 Feb 2025 09:32:49 +0800

On Feb 28, 2025 at 02:27 +0800, David G. Johnston <[email-masked]>, wrote:
> Thank you for the review.  If you would like to add yourself as the reviewer and mark this ready to commit here is the commitfest entry.
Hi, Done.

--
Zhang Mingli
HashData