Subject: Avoid unused value (src/fe_utils/print.c)

From: Ranier Vilela <[email-masked]>
Date: Sat, 3 Jun 2023 07:14:57 -0300

Hi,

This is for Postgres 17 (head).

Per Coverity.
At function print_unaligned_text, variable "need_recordsep", is
unnecessarily set to true and false.

Attached a trivial fix patch.

regards,
Ranier Vilela

---

From: Alexander Lakhin <[email-masked]>
Date: Sat, 3 Jun 2023 15:00:01 +0300

Hello Ranier,

> unnecessarily set to true and false.

Clang' scan-build detects 58 errors "Dead assignment", including that one.
Maybe it would be more sensible to eliminate all errors of this class?

Best regards,
Alexander