Subject: gitmaster server problem?

From: Bruce Momjian <[email-masked]>
Date: Sat, 17 Aug 2024 12:41:19 -0400

About 20 minutes ago I starting getting gitmaster pull errors:

	$ git pull ssh://[email-masked]/postgresql.git
	ssh: connect to host gitmaster.postgresql.org port 22: Connection timed
	out
	fatal: Could not read from remote repository.
	
	Please make sure you have the correct access rights
	and the repository exists.

Public git seems fine:

	$ git pull https://git.postgresql.org/git/postgresql.git
	From https://git.postgresql.org/git/postgresql
	 * branch                    HEAD       -> FETCH_HEAD
	Already up to date.

Can anyone confirm or report on the cause?

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: Tom Lane <[email-masked]>
Date: Sat, 17 Aug 2024 12:49:20 -0400

Bruce Momjian <[email-masked]> writes:
> ...

Yeah, for me it's hanging up at the connection establishment
stage ("ssh -fMN gitmaster.postgresql.org").  Traceroute gets
as far as some rackspace.net machines, but gemulon itself
isn't answering.

			regards, tom lane

---

From: Tom Lane <[email-masked]>
Date: Sat, 17 Aug 2024 13:22:18 -0400

> as far as some rackspace.net machines, but gemulon itself

ssh and git pull are working again now for me.

Oddly, "ping gemulon.postgresql.org" is still showing 98%+
packet drop rate.  Not sure if that's normal.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 17 Aug 2024 14:24:54 -0400

> ssh and git pull are working again now for me.

ssh and git pull are still failing for me to gitmaster.postgresql.org.

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 17 Aug 2024 14:53:44 -0400

> ssh and git pull are still failing for me to gitmaster.postgresql.org.

Joe Conway, CC'ed, is aware of the issue and is now working on it.

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 17 Aug 2024 15:04:31 -0400

> Joe Conway, CC'ed, is aware of the issue and is now working on it.

Joe reports that everything should be working normally now.