Subject: Re: pg_stat_statements: remove redundant function call in pg_stat_statements_internal

From: Julien Rouhaud <[email-masked]>
Date: Sun, 27 Feb 2022 19:55:26 +0800

Hi,

On Sun, Feb 27, 2022 at 08:45:13PM +0900, Dong Wook Lee wrote:
> 
> I found some redundant function calls in
> pg_stat_statements.c/pg_stat_statements_internal(),
> There is no need to call GetUserId() again because the value was
> previously obtained.

Indeed.  I doubt it will make any real difference but it doesn't hurt to fix
it.

Patch looks good to me.

---

From: Michael Paquier <[email-masked]>
Date: Sun, 27 Feb 2022 21:08:56 +0900

> Indeed.  I doubt it will make any real difference but it doesn't hurt to fix

Yes, let's clean up that on HEAD.  No objections from here.  I'll do
that tomorrow or so.
--
Michael

---

From: Michael Paquier <[email-masked]>
Date: Mon, 28 Feb 2022 11:02:09 +0900

> Yes, let's clean up that on HEAD.  No objections from here.  I'll do

And done.
--
Michael