Subject: Re: meson/msys2 fails with plperl/Strawberry

From: Andres Freund <[email-masked]>
Date: Mon, 27 Mar 2023 10:18:50 -0700

Hi,

On 2023-03-26 21:13:41 -0400, Andrew Dunstan wrote:
> > On Mar 26, 2023, at 5:28 PM, Andres Freund <[email-masked]> wrote:
> >> On 2023-03-26 12:39:08 -0700, Andres Freund wrote:
> >> First: I am *not* arguing we shouldn't repair building against strawberry perl
> >> with mingw.
> > 
> > Hm - can you describe the failure more - I just tried, and it worked to build
> > against strawberry perl on mingw, without any issues. All I did was set
> > -DPERL="c:/strawberrly/perl/bin/perl.exe".

> That might be the secret sauce I’m missing. I will be offline for a day or three, will test when I’m back.

It should suffice to put strawberry perl first in PATH. All that the -DPERL
does is to use that, instead of 'perl' from PATH. If putting strawberry perl
ahead in PATH failed, something else must have been going on...

Greetings,

Andres Freund

---

From: Andrew Dunstan <[email-masked]>
Date: Thu, 30 Mar 2023 11:00:01 -0400

On 2023-03-27 Mo 13:18, Andres Freund wrote:
>>> On Mar 26, 2023, at 5:28 PM, Andres Freund<[email-masked]>  wrote:

Yeah, What it actually needed was a system upgrade. Sorry for the noise.

cheers

andrew

--
Andrew Dunstan
EDB:https://www.enterprisedb.com