Subject: infobits_set WAL record struct field is int8

From: Peter Geoghegan <[email-masked]>
Date: Tue, 11 Apr 2023 13:13:49 -0700

Commit 0ac5ad5134 ("Improve concurrency of foreign key locking") added
infobits_set fields to certain WAL records. However, in the case of
xl_heap_lock, it made the data type int8 rather than uint8.

I believe that this was a minor oversight. Attached patch fixes the issue.

-- 
Peter Geoghegan

---

From: Andres Freund <[email-masked]>
Date: Tue, 11 Apr 2023 13:48:44 -0700

Hi,

> I believe that this was a minor oversight. Attached patch fixes the issue.

Makes sense. Looks like there never was a flag defined for the sign bit,
luckily. I assume you're just going to apply this for HEAD?

Greetings,

Andres Freund