Subject: New "blob" re-introduced?

From: Kyotaro Horiguchi <[email-masked]>
Date: Fri, 24 Feb 2023 16:31:27 +0900 (JST)

I noticed that the commit e9960732a9 introduced the following message.

+	if (EndCompressFileHandle(ctx->dataFH) != 0)
+		pg_fatal("could not close blob data file: %m");

It seems that we have removed the terminology "blob(s)" from
user-facing messages by the commit 35ce24c333 (discussion is [1]).
Shouldn't we use "large object" instead of "blob" in the message?

[1] https://www.postgresql.org/message-id/868a381f-4650-9460-1726-1ffd39a270b4%40enterprisedb.com

regards.

-- 
Kyotaro Horiguchi
NTT Open Source Software Center

---

From: Daniel Gustafsson <[email-masked]>
Date: Fri, 24 Feb 2023 08:38:44 +0100

> On 24 Feb 2023, at 08:31, Kyotaro Horiguchi <[email-masked]> wrote:

> Shouldn't we use "large object" instead of "blob" in the message?

Nice catch, it should be "large object" as per the linked discussion.  There
are also a few more like:

-       if (cfclose(ctx->LOsTocFH) != 0)
-               pg_fatal("could not close LOs TOC file: %m");
+       if (EndCompressFileHandle(ctx->LOsTocFH) != 0)
+               pg_fatal("could not close blobs TOC file: %m");

I'll go ahead and fix them, thanks for the report!

--
Daniel Gustafsson