Subject: [PATCH] Improve function toast_delete_external (src/backend/access/table/toast_helper.c)

From: Ranier Vilela <[email-masked]>
Date: Wed, 9 Feb 2022 07:56:35 -0300

Hi,

I think this change can improve this particular function by avoiding
touching value if not needed.
Test if not isnull is cheaper than test TupleDescAttr is -1.

best regards,

Ranier Vilela

---

From: Dong Wook Lee <[email-masked]>
Date: Wed, 9 Feb 2022 23:33:47 +0900

Hi,

I've applied your patch. I think it's reasonable.
but  IMHO It looks more complicated to read because of many conditions
in if statement.
so what about just moving up if-statement?

Thanks.
Dong Wook Lee

2022년 2월 9일 (수) 오후 7:56, Ranier Vilela <[email-masked]>님이 작성:
>
> Hi,
>
> I think this change can improve this particular function by avoiding touching value if not needed.