Subject: Question on compatibility of Postgres with Open JDK

From: Pratheej Chandrika <[email-masked]>
Date: Wed, 30 Jan 2019 11:58:04 +0530

Hello,
We are using Postgresql (postgresql-bdr94).

Please let us know whether Postgresql supports Open JDK?

Thanks
Pratheej

---

From: Craig Ringer <[email-masked]>
Date: Wed, 30 Jan 2019 14:33:56 +0800

I don't understand the question.

If you want to use PgJDBC, then yes, PgJDBC works on OpenJDK. You do not
need to use pgjdbc 9.4 with PostgreSQL 9.4, you may use the latest version.

If you want to use pl/java, then I don't know if it's been tested with
postgres-bdr 9.4. But it should work fine if it works with normal community
postgres 9.4.

On Wed, 30 Jan 2019 at 14:28, Pratheej Chandrika <
[email-masked]> wrote:

> --
> You received this message because you are subscribed to the Google Groups
> "Postgres-BDR and pglogical Mailing List" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> Visit this group at
> https://groups.google.com/a/2ndquadrant.com/group/bdr-list/.
> To view this discussion on the web visit
> https://groups.google.com/a/2ndquadrant.com/d/msgid/bdr-list/CA%2BOir%3DMAc9OU4iNm%3DRBr%2BF2fLOSjJTACT9X5brChBGVCAJdPzA%40mail.gmail.com
> <https://groups.google.com/a/2ndquadrant.com/d/msgid/bdr-list/CA%2BOir%3DMAc9OU4iNm%3DRBr%2BF2fLOSjJTACT9X5brChBGVCAJdPzA%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
>

-- 
 Craig Ringer                   http://www.2ndQuadrant.com/
 2ndQuadrant - PostgreSQL Solutions for the Enterprise

---

From: Pratheej Chandrika <[email-masked]>
Date: Wed, 30 Jan 2019 12:58:02 +0530

Criag,
Thanks a lot for the prompt reply.

---

From: Craig Ringer <[email-masked]>
Date: Wed, 30 Jan 2019 16:27:23 +0800

On Wed, 30 Jan 2019 at 15:28, Pratheej Chandrika <
[email-masked]> wrote:

> From what you mentioned, I assume that other the client side jdbc  there
> is no Java dependency from Server side. What I mean is I assume there is no
> jdk/java dependency for Postgres server to work. Request your input.
>

Correct.

Please see the PostgreSQL and PgJDBC manuals for more details.