Subject: Re: Question about non-blocking mode in libpq

From: Tom Lane <[email-masked]>
Date: Tue, 31 Oct 2023 22:16:07 -0400

Bruce Momjian <[email-masked]> writes:
> On Tue, Oct 31, 2023 at 09:11:06PM -0400, Tom Lane wrote:
>> What I'm objecting to is removal of the bit about "if they need to be
>> called again".  That provides a hint that retry is the appropriate
>> response to a failure.  Admittedly, it's not 100% clear, but your
>> version makes it 0% clear.

> I thought the original docs said you had to re-call on failure (it would
> not block but it would fail if it could not be sent), while we are now
> saying that it will be queued in the input buffer.

For these functions in nonblock mode, failure means "we didn't queue it".

> Is retry really something we need to mention now?  If out of memory is
> our only failure case now ("unable to enlarge the buffer because OOM"),
> is retry really a realistic option?

Well, ideally the application would do something to alleviate the
OOM problem before retrying.  I don't know if we want to go so far
as to discuss that.  I do object to giving the impression that
failure is impossible, which I think your proposed wording does.

An orthogonal issue with your latest wording is that it's unclear
whether *unsuccessful* calls to these functions will block.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 1 Nov 2023 08:47:33 -0400

> whether *unsuccessful* calls to these functions will block.

Okay, I see your point now.  Here is an updated patch that addresses
both issues.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.
diff --git a/doc/src/sgml/libpq.sgml b/doc/src/sgml/libpq.sgml
index 64b2910fee..ffff0e528d 100644
--- a/doc/src/sgml/libpq.sgml
+++ b/doc/src/sgml/libpq.sgml
@@ -5316,11 +5316,12 @@ int PQsetnonblocking(PGconn *conn, int arg);
       </para>
 
       <para>
-       In the nonblocking state, calls to
+       In the nonblocking state, successful calls to
        <xref linkend="libpq-PQsendQuery"/>, <xref linkend="libpq-PQputline"/>,
        <xref linkend="libpq-PQputnbytes"/>, <xref linkend="libpq-PQputCopyData"/>,
-       and <xref linkend="libpq-PQendcopy"/> will not block but instead return
-       an error if they need to be called again.
+       and <xref linkend="libpq-PQendcopy"/> will not block;  their changes
+       are stored in the local output buffer until they are flushed. 
+       Unsuccessful calls will return an error and must be retried.
       </para>
 
       <para>

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 13 Nov 2023 13:01:32 -0500

> Okay, I see your point now.  Here is an updated patch that addresses

Patch applied to master.

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 13 Nov 2023 14:05:23 -0500

> > Okay, I see your point now.  Here is an updated patch that addresses

My apologies, I forgot this needed to backpatched, so done now.