Subject: remove WaitEventCustomCounterData

From: Nathan Bossart <[email-masked]>
Date: Wed, 8 Jul 2026 21:50:33 -0500

While trying to understand the extent of our spinlock usage, I noticed that
WaitEventCustomCounterData->mutex is unnecessary because the counter is
only ever accessed with WaitEventCustomLock held exclusively.  So, here's a
patch to simplify matters a bit.  Thoughts?

-- 
nathan

---

From: Michael Paquier <[email-masked]>
Date: Thu, 9 Jul 2026 13:04:37 +0900

> patch to simplify matters a bit.  Thoughts?

Indeed.  This removal sounds good to me, thanks.
--
Michael

---

From: Fujii Masao <[email-masked]>
Date: Thu, 9 Jul 2026 13:22:52 +0900

> Indeed.  This removal sounds good to me, thanks.

#include "storage/spin.h" seems no longer needed in wait_event.c,
since the patch removes the last use of the spinlock code there.
So we can remove that include as well?

Regards,

-- 
Fujii Masao

---

From: Nathan Bossart <[email-masked]>
Date: Thu, 9 Jul 2026 11:10:19 -0500

> So we can remove that include as well?

I think so.  I've committed the patch with that change.  Thanks for
looking!

-- 
nathan