($INBOX_DIR/description missing)  
help / color / mirror / Atom feed
From: Nathan Bossart <[email protected]>
Subject: [PATCH v2 1/4] Rename pg_popcount_avx512.c to pg_popcount_x86.c.
Date: Wed, 14 Jan 2026 11:37:28 -0600

This is preparatory work for a follow-up commit that will move the
rest of the x86-64-specific popcount code to this file.
---
 src/port/Makefile                                    | 2 +-
 src/port/meson.build                                 | 2 +-
 src/port/{pg_popcount_avx512.c => pg_popcount_x86.c} | 6 +++---
 3 files changed, 5 insertions(+), 5 deletions(-)
 rename src/port/{pg_popcount_avx512.c => pg_popcount_x86.c} (98%)

diff --git a/src/port/Makefile b/src/port/Makefile
index 4274949dfa4..6e3b7d154ed 100644
--- a/src/port/Makefile
+++ b/src/port/Makefile
@@ -47,7 +47,7 @@ OBJS = \
 	pg_localeconv_r.o \
 	pg_numa.o \
 	pg_popcount_aarch64.o \
-	pg_popcount_avx512.o \
+	pg_popcount_x86.o \
 	pg_strong_random.o \
 	pgcheckdir.o \
 	pgmkdirp.o \
diff --git a/src/port/meson.build b/src/port/meson.build
index 28655142ebe..d7d4e705b89 100644
--- a/src/port/meson.build
+++ b/src/port/meson.build
@@ -10,7 +10,7 @@ pgport_sources = [
   'pg_localeconv_r.c',
   'pg_numa.c',
   'pg_popcount_aarch64.c',
-  'pg_popcount_avx512.c',
+  'pg_popcount_x86.c',
   'pg_strong_random.c',
   'pgcheckdir.c',
   'pgmkdirp.c',
diff --git a/src/port/pg_popcount_avx512.c b/src/port/pg_popcount_x86.c
similarity index 98%
rename from src/port/pg_popcount_avx512.c
rename to src/port/pg_popcount_x86.c
index 407b610bacb..453c7a06ce9 100644
--- a/src/port/pg_popcount_avx512.c
+++ b/src/port/pg_popcount_x86.c
@@ -1,12 +1,12 @@
 /*-------------------------------------------------------------------------
  *
- * pg_popcount_avx512.c
- *	  Holds the AVX-512 pg_popcount() implementation.
+ * pg_popcount_x86_64.c
+ *	  Holds the x86-64 pg_popcount() implementations.
  *
  * Copyright (c) 2024-2026, PostgreSQL Global Development Group
  *
  * IDENTIFICATION
- *	  src/port/pg_popcount_avx512.c
+ *	  src/port/pg_popcount_x86_64.c
  *
  *-------------------------------------------------------------------------
  */
-- 
2.50.1 (Apple Git-155)


--KuW0xlRTZoVkcm/J
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment;
	filename=v2-0002-Move-x86-popcount-code-to-pg_popcount_x86_64.c.patch



view thread (2+ messages)

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected]
  Subject: Re: [PATCH v2 1/4] Rename pg_popcount_avx512.c to pg_popcount_x86.c.
  In-Reply-To: <no-message-id-77496@localhost>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox