Subject: remove the unneeded header file math.h in binaryheap.c

From: "liujinyang" <[email-masked]>
Date: Tue, 13 Jan 2026 17:21:30 +0800

Hi Hackers,

I found in file binaryheap.c， file "math.h" was included, but it is uncessary, so I removed it&nbsp;

and filing a patch to address the issue.

I have verified that, build is OK.

Please see the attachment and help review it.

thanks a lot!

liujinyang

---

From: Álvaro Herrera <[email-masked]>
Date: Tue, 13 Jan 2026 18:18:19 +0100

> and filing a patch to address the issue.

Fun.  This was already unnecessary at commit 7a2fe9bd0371 which
introduced the file.  It seems Abhijit had that include in his first
version [1] because he was using floor().   Robert rewrote it later [2]
and replaced that with straight arithmetic, making the include
unnecessary, but forgot to remove it.

[1] https://postgr.es/m/[email-masked] 
[2] https://postgr.es/m/CA%2BTgmobvR7XW9fjj2RNY7sKK-VAG5nahfai_zV51rHVLDNvaBg%40mail.gmail.com

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/