Subject: [PATCH] libpq: Fix incorrect message type in getBackendKeyData() comment

From: "zourenli" <[email-masked]>
Date: Thu, 26 Feb 2026 11:01:29 +0800

Hi all, &nbsp;

This is a trivial fix for the comment of getBackendKeyData() function in fe-protocol3.c. &nbsp;
The comment incorrectly stated that the BackendKeyData message type is 'v', when in fact it is 'K' as defined in protocol.h. This fix corrects the comment to match the actual message type used in the protocol. &nbsp;
No functional changes are involved. &nbsp;

Patch is attached below. &nbsp;

Thanks, &nbsp;
zourenli &nbsp;
<[email-masked]&gt;

---

From: Michael Paquier <[email-masked]>
Date: Mon, 16 Mar 2026 16:00:36 +0900

On Thu, Feb 26, 2026 at 11:01:29AM +0800, zourenli wrote:
> The comment incorrectly stated that the BackendKeyData message type
> is 'v', when in fact it is 'K' as defined in protocol.h. This fix
> corrects the comment to match the actual message type used in the
> protocol.

As in PqMsg_BackendKeyData, good catch.  Grabbed this one.
--
Michael