Subject: How to find whether a cursor can scroll with libpq

From: Luiz Fernandes <[email-masked]>
Date: Tue, 9 Mar 2021 10:40:25 -0300

Hi,

Is it possible to find with libpq whether a cursor can scroll or not, 
given the connection and the name of the cursor?

Thanks,
Luiz Fernandes

---

From: Dmitry Igrishin <[email-masked]>
Date: Tue, 9 Mar 2021 17:49:53 +0300

> given the connection and the name of the cursor?
No. But there is a system view --
https://www.postgresql.org/docs/current/view-pg-cursors.html

---

From: Luiz Fernandes <[email-masked]>
Date: Tue, 9 Mar 2021 13:49:58 -0300

Thanks, Dmitry.
So, I can try to obtain this info querying this view.

Regards,
Luiz