Received: from localhost (unknown [200.46.204.183]) by developer.postgresql.org (Postfix) with ESMTP id 583142E0033 for ; Tue, 10 Jun 2008 20:05:30 -0300 (ADT) Received: from developer.postgresql.org ([200.46.204.71]) by localhost (mx1.hub.org [200.46.204.183]) (amavisd-maia, port 10024) with ESMTP id 33888-07 for ; Tue, 10 Jun 2008 20:05:23 -0300 (ADT) X-Greylist: from auto-whitelisted by SQLgrey-1.7.6 Received: from sss.pgh.pa.us (sss.pgh.pa.us [66.207.139.130]) by developer.postgresql.org (Postfix) with ESMTP id 683012E0086 for ; Tue, 10 Jun 2008 20:05:27 -0300 (ADT) Received: from sss2.sss.pgh.pa.us (tgl@localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.2/8.14.2) with ESMTP id m5AN5P5K026210; Tue, 10 Jun 2008 19:05:25 -0400 (EDT) To: Edward Amsden cc: pgsql-interfaces@postgreSQL.org Subject: Re: pqlib large object error In-reply-to: <1213134089.15557.22.camel@dad-desktop2> References: <1213118594.9123.11.camel@dad-desktop2> <21991.1213122593@sss.pgh.pa.us> <1213130242.15557.3.camel@dad-desktop2> <24396.1213130996@sss.pgh.pa.us> <1213134089.15557.22.camel@dad-desktop2> Comments: In-reply-to Edward Amsden message dated "Tue, 10 Jun 2008 17:41:29 -0400" Date: Tue, 10 Jun 2008 19:05:25 -0400 Message-ID: <26209.1213139125@sss.pgh.pa.us> From: Tom Lane X-Virus-Scanned: Maia Mailguard 1.0.1 X-Archive-Number: 200806/9 X-Sequence-Number: 6752 Edward Amsden writes: > On Tue, 2008-06-10 at 16:49 -0400, Tom Lane wrote: >> Hmph. The only thing I can think of is that that index is corrupt, >> but it seems unlikely that it would be so in all databases. What >> happens if you REINDEX pg_largeobject? > The error has disappeared. Hmm, so something did happen to your index. > Now it can't write to the object. lo_open > seems to be successful, but lo_write is failing with: >> ERROR: invalid large-object descriptor: 0 You forgot to put the open-and-use-descriptor sequence inside a BEGIN block. regards, tom lane