Subject: [pgjdbc/pgjdbc]

From: "renovate[bot]" <[email-masked]>
Date: Sat, 11 Feb 2023 11:31:59 -0800

Branch: refs/heads/renovate/com.github.johnrengelman.shadow-5.x
  Home:   https://github.com/pgjdbc/pgjdbc

---

From: Kevin Wooten <[email-masked]>
Date: Sat, 11 Feb 2023 12:32:59 -0700

These are getting ridiculous.

> On Feb 11, 2023, at 12:31 PM, renovate[bot] <[email-masked]> wrote:
>

---

From: Vladimir Sitnikov <[email-masked]>
Date: Sat, 11 Feb 2023 22:42:07 +0300

Sorry for the noise.
We have not updated dependencies for a while, so there's a bunch of them to
update.

I hope the noise would be much less as we update.

Here's the dashboard (~20 dependencies left):
https://github.com/pgjdbc/pgjdbc/issues/2768

Vladimir

---

From: Kevin Wooten <[email-masked]>
Date: Sat, 11 Feb 2023 12:44:02 -0700

Am I wrong or is it sending a notification for each branch, commit, and merge?

> On Feb 11, 2023, at 12:42 PM, Vladimir Sitnikov <[email-masked]> wrote:
> 
> Sorry for the noise.
> We have not updated dependencies for a while, so there's a bunch of them to update.
>

---

From: Vladimir Sitnikov <[email-masked]>
Date: Sat, 11 Feb 2023 22:52:06 +0300

> Am I wrong or is it sending a notification for each branch, commit, and merge?

I guess so.
It creates branches right within pgjdbc/pgjdbc repository so save
resources on forking every repository.

I've no idea if we can divert renovate to a different mailing list though.

Vladimir

---

From: Dave Cramer <[email-masked]>
Date: Sat, 11 Feb 2023 14:53:31 -0500

> I've no idea if we can divert renovate to a different mailing list though.

I'm sort of surprised we have that many dependencies

Is there no way to do them all at once ?

Dave

---

From: Vladimir Sitnikov <[email-masked]>
Date: Sat, 11 Feb 2023 23:03:10 +0300

> Is there no way to do them all at once ?

Some of them require manual corrections.
For instance, Checkstyle 10 requires Java 11, so we need to do
something (e.g. run Checkstyle with Java 11+ only)

We can probably combine dependencies if testing locally (e.g. prepare
a PR with all the updates),
however I guess it might be easier to squeeze them one-by-one.

Vladimir

---

From: Kevin Wooten <[email-masked]>
Date: Sat, 11 Feb 2023 13:06:00 -0700

I’d argue that merges are all this list needs… if that. Considering the target audience, releases (which already summarize the changes) is probably all that is really needed.

> On Feb 11, 2023, at 1:03 PM, Vladimir Sitnikov <[email-masked]> wrote:
>

---

From: Vladimir Sitnikov <[email-masked]>
Date: Sat, 11 Feb 2023 23:12:23 +0300

Fair.
I guess we could move git activity to pgsql-jdbc-commits list

Vladimir

-- 
Vladimir