Subject: Regarding UUID

From: lekha Tripathi <[email-masked]>
Date: Wed, 8 Feb 2023 15:25:42 +0530

Hi,
I am having a table with a column type UUID and to insert this column value
i am having value like "1344443456" in text datatype and i want to insert
this value as UUID .
While trying to insert this value getting error for UUID ,
So is any way to convert my given value into customised UUID?
Let me know if any way to do so.

Regards
Lekha

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 08 Feb 2023 11:21:17 +0100

On Wed, 2023-02-08 at 15:25 +0530, lekha Tripathi wrote:
> I am having a table with a column type UUID and to insert this column value i
> am having value like "1344443456" in text datatype and i want to insert this value as UUID .

That does not look like a valid UUID at all.  I have no idea how that could be
converted to an UUID, same as I don't know how "hello" should be converted to
a timestamp.  Perhaps you have some more information?

Yours,
Laurenz Albe

---

From: Antoine Besnier <[email-masked]>
Date: Wed, 8 Feb 2023 10:37:19 +0000 (UTC)

You'd need to convert your string to a valid UUID first.See https://stackoverflow.com/questions/29059530/is-there-any-way-to-generate-the-same-uuid-from-a-string for ideas
What do you mean by "customised UUID"? UUID format is standardized by definition.

But that looks like a X-Y problem. If you already have an ID, why generate a new one?

Antoine

    Le mercredi 8 février 2023 à 11:21:24 UTC+1, Laurenz Albe <[email-masked]> a écrit :  

Yours,
Laurenz Albe