Subject: PostgreSQL JDBC 42.7.5 returns an unexpected catalog name

From: Vinhson Nguyen <[email-masked]>
Date: Fri, 28 Mar 2025 18:24:22 +0000

1) Problem Description:  
When upgrading our application to a new PostgreSQL JDBC driver 42.7.5 (from 42.7.4), we got an expected catalog name in the result set returned by DatabaseMetadata.getSchemas().

Expected catalog name:  null (42.7.4) 
Unexpected catalog name:  dbcert (42.7.5)

2) Connection Info:
URL used:
jdbc:postgresql://cteds721.fyre.ibm.com:54172/dbcert

Driver name/Version:
org.postgresql.Driver/postgresql-42.7.5.jar

userID/pw: dbcert1/***********

3) Attachements:
a) PG_JDBC_42_7_4.PNG:  Screenshot showing an expected catalog name (null) with driver version 42.7.4.
b) PG_JDBC_42_7_5.PNG:  Screenshot showing an unexpected catalog name (dbcert) with driver version 42.7.5.
c) ImportTest.java:  Java test program used in (a) and (b).

If you need any additional details, please let me know.

Thank you in advance!
Vinhson Nguyen

---

From: Laurenz Albe <[email-masked]>
Date: Sat, 29 Mar 2025 17:21:09 +0100

I think this belongs here.

-------- Forwarded Message --------
From: Vinhson Nguyen <[email-masked]>
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>

1) Problem Description:  

2) Connection Info:
URL used:

Driver name/Version:

3) Attachements:

Thank you in advance!
Vinhson Nguyen

---

From: Andrew Dunstan <[email-masked]>
Date: Sat, 29 Mar 2025 14:53:53 -0400

> If you need any additional details, please let me know.

You should probably raise this here: 
<https://github.com/pgjdbc/pgjdbc/issues>

cheers

andrew

--
Andrew Dunstan
EDB: https://www.enterprisedb.com