Subject: Regarding setClob and getclobval methods in PostgreSQL

From: Rajyalakshmi Sareddy <[email-masked]>
Date: Mon, 3 Feb 2025 09:22:10 +0000

Hi Team,

We are currently migrating the code from oracle to postgresql and using jdbc jar is postgresql-42.7.4.jar. But for code migration, we are getting errors like org.postgresql.jdbc.PgPreparedStatement.setClob(int, Reader) is not yet implemented.

Could you please confirm on setClob and getclobval methods are implemented in postgresql-42.7.4 jar.  If not implemented, could you please suggest with alternate methods.

Thanks and Regards
Rajyalakshmi Sareddy
Integration Developer
Middleware & Integration
GSK Tech
Hyderabad, India

E: [email-masked]<mailto:[email-masked]>
M: +91 8309974485

GSK monitors email communications sent to and from GSK in order to protect GSK, our employees, customers, suppliers and business partners, from cyber threats and loss of GSK Information. GSK monitoring is conducted with appropriate confidentiality controls and in accordance with local laws and after appropriate consultation.

---

From: Dave Cramer <[email-masked]>
Date: Wed, 5 Feb 2025 08:31:11 -0500

Hello,

You are correct that it is not implemented.

What is implemented is setClob(int, Clob)
https://github.com/pgjdbc/pgjdbc/blob/15596302e6ab9ccdefe25c9bd91284d5f232ee27/pgjdbc/src/main/java/org/postgresql/jdbc/PgPreparedStatement.java#L1328

However I'm not sure there is any reason that it hasn't been implemented
yet.

Feel free to provide a PR to implement it.

Dave Cramer
www.postgres.rocks

On Mon, 3 Feb 2025 at 09:44, Rajyalakshmi Sareddy <
[email-masked]> wrote:

> Hi Team,
>
>
>
> We are currently migrating the code from oracle to postgresql and using
> jdbc jar is *postgresql-42.7.4.jar.* But for code migration, we are
> getting errors like org.postgresql.jdbc.PgPreparedStatement.*setClob(int,
> Reader) is not yet implemented*.
>
>
>
> Could you please confirm on setClob and getclobval methods are implemented
> in postgresql-42.7.4 jar.  If not implemented, could you please suggest
> with alternate methods.
>
>
>
> Thanks and Regards
>
> Rajyalakshmi Sareddy
>
> Integration Developer
>
> Middleware & Integration
>
> GSK Tech
>
> Hyderabad, India
>
>
>
> E: [email-masked]
>
> M: +91 8309974485
>
>
>
> *GSK monitors email communications sent to and from GSK in order to
> protect GSK, our employees, customers, suppliers and business partners,
> from cyber threats and loss of GSK Information. GSK monitoring is conducted
> with appropriate confidentiality controls and in accordance with local laws
> and after appropriate consultation.*
>