Subject: PostgreSQL Data Engineer, Glyfada, Athens, Greece

From: Achilleas Mantzios <[email-masked]>
Date: Wed, 14 Feb 2024 09:25:38 +0200

PostgreSQL Data Engineer

Job description

This is a position within Dynacom Tankers Mgmt - IT Dept. Our core business
is ship owning, ship management, shipyards and other business fields as
well.

Our team consists of experienced programmers, administrators and engineers
who constantly deliver state of the art products and services to the
company's departments, subsidiaries and vessels.

The Candidate will be responsible for the design, testing, maintenance,
monitoring of the company's DB systems.

Responsibilities:

   -

   Design efficient architectures around PostgreSQL
   -

   Troubleshoot slow queries
   -

   Monitor for performance,  database health, correct table and index
   bloating, etc
   -

   Understand our current architecture and maintain it
   -

   Work closely with the sysadms in order to deliver the best design
   -

   Work closely with the dev team in order to help deliver efficient
   software and systems
   -

   Add value to the company by helping with OLAP
   -

   Take part of a very large PostgreSQL upgrade across 100s of installations

Required skills:

   -

   At least 3 years of working with PostgreSQL, versions from 10 upwards
   -

   Knowledge of PL/pgSQL, functions, procedures
   -

   Experience with PostgreSQL on Linux or BSD
   -

   Solid knowledge of fundamental PostgreSQL concepts
   -

   Great SQL skills
   -

   Great Unix/Linux/BSD skills, OS knowledge, Bash, awk, sed etc
   -

   High level of understanding of the whole stack of a software system

Nice to have:

   -

   pgbadger, pg_stat_statements
   -

   pgbouncer, pgpool2
   -

   pgbackrest  or other backup software
   -

   Logical Replication, Physical Replication + PITR
   -

   Major PostgreSQL upgrade experience
   -

   java experience is big plus
   -

   mysql, MS SQL skills are more than welcome
   -

   perl, python

We offer:

   -

   Competitive compensation, above market average
   -

   Stable working environment

---

From: Achilleas Mantzios <[email-masked]>
Date: Sun, 18 Feb 2024 10:24:37 +0200

Dear All

just an amendment to the job ad. It is an onsite job. Not remote.

On Wed, 14 Feb 2024 at 09:25, Achilleas Mantzios <[email-masked]>
wrote:

> PostgreSQL Data Engineer
>
> Job description
>
> This is a position within Dynacom Tankers Mgmt - IT Dept. Our core
> business is ship owning, ship management, shipyards and other business
> fields as well.
>