Subject: No console output from PostgresSQL binaries on fresh windows install

From: <[email-masked]>
Date: Wed, 28 Oct 2020 12:54:37 +0100

Good day everyone,

when trying to run the official PG 13 binaries on a fresh Windows 10 VM the application exists immediately with exit code -1073741515 and produces no console output of any kind.

After PostgreSQL as been installed on the machine using the installer, the binaries work fine, even after removing the installation again.

The described behavior occurs on any of the executables in the /bin folder (pg_cts, initdb, pg_dump, ...). I’ve tested this on multible Windows 10 Pro VM’s (Azure Vm, local VM) .

Are there any obvious dependencies I‘m missing? 

Thank you for your time,

  Tim

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 28 Oct 2020 14:10:00 +0100

On Wed, 2020-10-28 at 12:54 +0100, [email-masked] wrote:
> when trying to run the official PG 13 binaries on a fresh Windows 10 VM the application exists
>  immediately with exit code -1073741515 and produces no console output of any kind.

You mean "exits", not "exists", right?

> After PostgreSQL as been installed on the machine using the installer, the binaries
>  work fine, even after removing the installation again. 
> 
> The described behavior occurs on any of the executables in the /bin folder (pg_cts, initdb, pg_dump, ...).
>  I’ve tested this on multible Windows 10 Pro VM’s (Azure Vm, local VM) .

Hard to say - perhaps there was something missing in the PATH, so that
required shared libraries could not be found?

Yours,
Laurenz Albe
-- 
Cybertec | https://www.cybertec-postgresql.com

---

From: <[email-masked]>
Date: Wed, 28 Oct 2020 14:42:49 +0100

> You mean "exits", not "exists", right?

You are right, of course.

> Hard to say - perhaps there was something missing in the PATH, so that required shared libraries could not be found?

Have you got any idea where I would find more information on that? I not able to find anything but the build dependencies on the topic.
If not, I might have to consider another way of implementing PostgreSQL as a backend for my application. (possibly a headless installer)

Appreciate your time,
  Tim Sandner

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 28 Oct 2020 16:38:34 +0100

> If not, I might have to consider another way of implementing PostgreSQL as a backend for my application. (possibly a headless installer)

I guess you don't find anything about that in the installation section because it
is operating system specific.

PostgreSQL does not consist of statically linked monolithic executables, but
it requires shared libraries for its operation (DLL in Windows).

The required shared libraries are included in the binary Windows distribution.
But you have to configure the shared library search path, otherwise Windows
won't find the shared libraries.  On windows, the PATH environment variable
doubles as shared library search path.

Ask your system administrator or perform a web search about PATH on Windows.

Yours,
Laurenz Albe