Subject: How to create a View of geometry type equals point?

From: Nicholas G Lawrence <[email-masked]>
Date: Fri, 14 Jun 2024 03:50:31 +0000

Hello pgsql-novice,

I want to create a View within PostGIS that filters only those records that have Geometry type equal to Point
(and also another view of geometry type equal to Polygon)
What SELECT statement achieves this?

Thanks,

Nick Lawrence
Senior Spatial Science Officer | Geospatial Technologies
Engineering & Technology | Transport and Main Roads

Floor 19 | 313 Adelaide Street | Brisbane City Qld 4000
GPO Box 1412 | Brisbane City Qld 4001
P: (07) 30667977
E: [email-masked]<mailto:[email-masked]>
W: www.tmr.qld.gov.au<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.tmr.qld.gov.au_&d=DwMFAg&c=tpTxelpKGw9ZbZ5Dlo0lybSxHDHIiYjksG4icXfalgk&r=B7lks60cqtX0KvQXGVj8MbkZJQP0MAFzax_Bmdw0hOA&m=oK6xl56P5IxMSPEf8JQbFBSpJihJZHSNA6rNzgUM1_E&s=v6_q-k1ArpX6YM1NqnIOVudS4W5Ulmhgs1t4YXykjH4&e=>

WARNING: This email (including any attachments) may contain legally privileged, confidential or private information and may be protected by copyright. You may only use it if you are the person(s) it was intended to be sent to and if you use it in an authorised way. No one is allowed to use, review, alter, transmit, disclose, distribute, print or copy this email without appropriate authority.

If this email was not intended for you and was sent to you by mistake, please telephone or email me immediately, destroy any hard copies of this email and delete it and any copies of it from your computer system. Any right which the sender may have under copyright law, and any legal privilege and confidentiality attached to this email is not waived or destroyed by that mistake.

It is your responsibility to ensure that this email does not contain and is not affected by computer viruses, defects or interference by third parties or replication problems (including incompatibility with your computer system).

Opinions contained in this email do not necessarily reflect the opinions of the Department of Transport and Main Roads, or endorsed organisations utilising the same infrastructure.

---

From: Sándor Daku <[email-masked]>
Date: Fri, 14 Jun 2024 06:36:26 +0200

Hello Nicholas,

> What SELECT statement achieves this?

I'm not familiar with PostGIS, but based on a quick glance at the docs I
think the ST_Dimension function is what you need. Something like: ...where
ST_Dimension(geometry_field) = 0

Regards,

Sándor

---

From: Roxanne Reid-Bennett <[email-masked]>
Date: Fri, 14 Jun 2024 06:38:13 +0000

Create view polys as
Select * from <table> where ST_GeometryType(<geom>) = ‘ST_Polygon’;

Returns ST_Linestring, ST_Polygon, etc.

ST_GeometryType
postgis.net

There is also GeometryType 
GeometryType
postgis.net

Roxanne

On Jun 13, 2024, at 9:36 PM, Sándor Daku <[email-masked]> wrote:

Hello Nicholas,

I'm not familiar with PostGIS, but based on a quick glance at the docs I think the ST_Dimension function is what you need. Something like: ...where ST_Dimension(geometry_field) = 0

Regards,

Sándor