Subject: Where does PostgreSQL store extensions on OpenSUSE?

From: Simon Connah <[email-masked]>
Date: Wed, 09 Jun 2021 11:07:41 +0000

Hi,

My old computer broke and I've completely forgotten where OpenSUSE stores its PostgreSQL extensions. I've been searching with DuckDuckGo but no luck. Is there a quick command to find out where to put them?

Thank you.

Simon.

---

From: Keith <[email-masked]>
Date: Wed, 9 Jun 2021 09:39:16 -0400

If you can run the "pg_config" binary, it should be able to show you where
SHAREDIR and LIBDIR are. Extension files are kept in $SHAREDIR/extensions
and any library files that may be associated with them will be in $LIBDIR.
Example for my custom build...

$ pg_config
BINDIR = /opt/pgsql1302/bin
DOCDIR = /opt/pgsql1302/share/doc
HTMLDIR = /opt/pgsql1302/share/doc
INCLUDEDIR = /opt/pgsql1302/include
PKGINCLUDEDIR = /opt/pgsql1302/include
INCLUDEDIR-SERVER = /opt/pgsql1302/include/server
LIBDIR = /opt/pgsql1302/lib
[...]

On Wed, Jun 9, 2021 at 7:07 AM Simon Connah <[email-masked]>
wrote:

> Hi,
>
> My old computer broke and I've completely forgotten where OpenSUSE stores
> its PostgreSQL extensions. I've been searching with DuckDuckGo but no luck.
> Is there a quick command to find out where to put them?
>
> Thank you.
>
> Simon.
>

---

From: Tom Lane <[email-masked]>
Date: Wed, 09 Jun 2021 09:41:11 -0400

> My old computer broke and I've completely forgotten where OpenSUSE stores its PostgreSQL extensions. I've been searching with DuckDuckGo but no luck. Is there a quick command to find out where to p…

If pg_config is installed, see "pg_config --sharedir" ---
extension-related text files should be under the extension/
subdirectory of that.  Meanwhile, any related .so files should
be in "pg_config --libdir" (or maybe it's --pkglibdir?  Not sure
because they're the same by default)

			regards, tom lane

---

From: Simon Connah <[email-masked]>
Date: Wed, 09 Jun 2021 15:04:03 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Wednesday, June 9th, 2021 at 14:41, Tom Lane <[email-masked]> wrote:

> Simon Connah [email-masked] writes:
> 

> regards, tom lane

Awesome. Thank you both. That solved the problem.

Simon.