Subject: ER diagram tools?

From: Ron Watkins <[email-masked]>
Date: Fri, 9 Feb 2024 12:11:35 -0700

Are there any decent free ER diagram tools for Postgres?

-- 
Ron Watkins, K7DOG
602.743.5272

---

From: TIM CHILD <[email-masked]>
Date: Fri, 9 Feb 2024 12:55:38 -0800 (PST)

Well Copilot says

> Copilot
> Certainly! When it comes to creating Entity-Relationship Diagrams (ERDs) for PostgreSQL, you have several options. Let me share some tools that you might find useful:
>  
> 1. pgAdmin 4:
>  
> o Description: pgAdmin 4 is a powerful open-source administration and management tool for PostgreSQL. It includes an ERD tool that allows you to design and visualize database tables and their relationships.
> o Features:
> + Design and visualize tables and relationships.
> + Add notes to the diagram.
> + Auto-align tables and links for cleaner visualization.
> + Save and reopen diagrams.
> + Generate SQL from the design.
> + Create ERDs from existing databases, schemas, or tables.
> o Reference:  https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html1 https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html
> 2. Vertabelo:
>  
> o Description: Vertabelo is an online data modeling tool with ERD capabilities for PostgreSQL (as well as other databases like MySQL, Microsoft SQL Server, Oracle, and SQLite).
> o Features:
> + Conceptual, logical, and physical data model design.
> + Visualize relationships.
> o Reference:  https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html2 https://bing.com/search?q=free+ER+diagram+tools+for+Postgres
> 3. Navicat:
>  
> o Description: Navicat provides an ER diagram tool for visually designing conceptual, logical, and physical data models specifically for PostgreSQL.
> o Features:
> + Design tables and relationships.
> o Reference:  https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html2 https://bing.com/search?q=free+ER+diagram+tools+for+Postgres
> 4. Visual Paradigm:
>  
> o Description: Visual Paradigm offers a comprehensive suite of modeling tools, including ERD capabilities for PostgreSQL.
> o Features:
> + Advanced modeling features.
> o Reference:  https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html2 https://bing.com/search?q=free+ER+diagram+tools+for+Postgres
> 5. SqlDBM:
>  
> o Description: SqlDBM is an online database modeling tool that supports PostgreSQL. It allows you to create ERDs and collaborate with team members.
> o Features:
> + Collaborative design.
> o Reference:  https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html2 https://bing.com/search?q=free+ER+diagram+tools+for+Postgres
> 6. ERDPlus:
>  
> o Description: ERDPlus is a free online tool for creating ERDs. While it’s not PostgreSQL-specific, it’s easy to use and suitable for various databases.
> o Features:
> + Simple and intuitive interface.
> o Reference:  https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html2 https://bing.com/search?q=free+ER+diagram+tools+for+Postgres
> Remember to explore these tools and choose the one that best fits your needs. Happy diagramming! 📊🔍
>  
>  
> 
> 
> Learn more
> 
> 1pgadmin.org https://www.pgadmin.org/docs/pgadmin4/development/erd_tool.html2bing.com https://bing.com/search?q=free+ER+diagram+tools+for+Postgres3youtube.com https://www.youtube.com/watch?v=o23LBJ-9jsU4youtube.com https://www.youtube.com/watch?v=2pxVCzRFGeg5youtube.com https://www.youtube.com/watch?v=mjQW2vO6_kY6dbmstools.com https://dbmstools.com/categories/database-diagram-tools/postgresql7dbdiagrams.com https://www.dbdiagrams.com/postgresql/online-er-diagram-postgresql-pagila-sample/8datensen.com https://www.datensen.com/blog/docs/postgresql-er-diagram/
>  
> 1of5
>  
> Show learn more suggestions
>  
>  
>  
> New topic
> New topic
>  
>

---

From: GERALD CHEVES <[email-masked]>
Date: Sun, 11 Feb 2024 18:01:56 -0500

M

On Feb 9, 2024, at 3:56 PM, TIM CHILD <[email-masked]> wrote:

Well Copilot says

Copilot

pgAdmin 4:

Description: pgAdmin 4 is a powerful open-source administration and management tool for PostgreSQL. It includes an ERD tool that allows you to design and visualize database tables and their relationships.

Features:

Design and visualize tables and relationships.

Add notes to the diagram.

Auto-align tables and links for cleaner visualization.

Save and reopen diagrams.

Generate SQL from the design.

Create ERDs from existing databases, schemas, or tables.

Reference: 1

Vertabelo:

Description: Vertabelo is an online data modeling tool with ERD capabilities for PostgreSQL (as well as other databases like MySQL, Microsoft SQL Server, Oracle, and SQLite).

Features:

Conceptual, logical, and physical data model design.

Visualize relationships.

Reference: 2

Navicat:

Description: Navicat provides an ER diagram tool for visually designing conceptual, logical, and physical data models specifically for PostgreSQL.

Features:

Design tables and relationships.

Reference: 2

Visual Paradigm:

Description: Visual Paradigm offers a comprehensive suite of modeling tools, including ERD capabilities for PostgreSQL.

Features:

Advanced modeling features.

Reference: 2

SqlDBM:

Description: SqlDBM is an online database modeling tool that supports PostgreSQL. It allows you to create ERDs and collaborate with team members.

Features:

Collaborative design.

Reference: 2

ERDPlus:

Description: ERDPlus is a free online tool for creating ERDs. While it’s not PostgreSQL-specific, it’s easy to use and suitable for various databases.

Features:

Simple and intuitive interface.

Reference: 2

Learn more

1pgadmin.org2bing.com3youtube.com4youtube.com5youtube.com6dbmstools.com7dbdiagrams.com8datensen.com

1of5

New topic

New topic

How about SQL Workbench for PostgreSQL?

phoenixnap.com/kb/postgresql-workbench

I’ve also used Smartdraw and Lucidchart but there’s a subscription fee.