Subject: Nested Procedures

From: DAVID ROTH <[email-masked]>
Date: Mon, 19 Jul 2021 14:20:36 -0400 (EDT)

Can I nest the definition of a procedure inside on another definition?
I am used to doing this in Oracle PL/SQL where a local procedure can be defined inside the declaration section of another procedure.

I am looking for 2 things as part of a migration effort.
1) Best way to replace Oracle packages.
2) Best way to define "private" procedures and functions.

Thanks
Dave R

---

From: Amul Sul <[email-masked]>
Date: Tue, 20 Jul 2021 09:13:03 +0530

PostgreSQL doesn't have those options, but EDB Postgres Advanced
Server does provide that.

Regards,
Amul