Subject: Naming projects for Postgresql ONLY.

From: Jean Baro <[email-masked]>
Date: Tue, 16 Nov 2021 13:39:55 -0300

Hi there,

I am working on a project for PERSON (Lead, Prospect and Customer)
deduplication that is done using 100% Postgresql capabilities (and its
standard extensions present in AWS, GCP and Azure as well). Once
extensively tested and robust enough I am planning on releasing it as Open
Source (probably under PG License).

To ensure people looking into this know it's a Postgresql only solution I
was considering naming it pg_person_dedupe or something on those lines.

Please, am I allowed to use pg_** as the name of this open source project?

Any suggestions recommendation would be really appreciated.

Thanks

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 17 Nov 2021 16:42:05 +0100

On Tue, 2021-11-16 at 13:39 -0300, Jean Baro wrote:
> I am working on a project for PERSON (Lead, Prospect and Customer) deduplication that
> is done using 100% Postgresql capabilities (and its standard extensions present in AWS,
> GCP and Azure as well). Once extensively tested and robust enough I am planning on
> releasing it as Open Source (probably under PG License). 
> 
> To ensure people looking into this know it's a Postgresql only solution I was considering naming it pg_person_dedupe or something on those lines.
> 

I see no problem with that.

Yours,
Laurenz Albe
-- 
Cybertec | https://www.cybertec-postgresql.com

---

From: Jean Baro <[email-masked]>
Date: Wed, 17 Nov 2021 13:46:44 -0300

Great, thanks!

Em qua., 17 de nov. de 2021 12:42, Laurenz Albe <[email-masked]>
escreveu:

> deduplication that
> > To ensure people looking into this know it's a Postgresql only solution
> I was considering naming it pg_person_dedupe or something on those lines.
> >

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 18 Nov 2021 12:30:13 -0500

> I see no problem with that.

Agreed, you might want to look here:

	https://www.postgresql.org/about/policies/trademarks/

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  If only the physical world exists, free will is an illusion.

---

From: Tom Lane <[email-masked]>
Date: Thu, 18 Nov 2021 12:33:32 -0500

> 	https://www.postgresql.org/about/policies/trademarks/

Note that there is no trademark on "pg", so those policies don't
really apply here.  I concur that there's no issue with Jean
using "pg" as a name prefix --- there are lots of other people
doing the same.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 18 Nov 2021 12:38:28 -0500

> using "pg" as a name prefix --- there are lots of other people

Yes, good point.

---

From: Jean Baro <[email-masked]>
Date: Thu, 18 Nov 2021 14:40:28 -0300

Great, thanks!

---

From: James Pitchford <[email-masked]>
Date: Thu, 18 Nov 2021 12:42:42 -0500

Please can someone advise how to remove myself from this email list.

Jim

---

From: Tom Lane <[email-masked]>
Date: Thu, 18 Nov 2021 12:50:49 -0500

> Please can someone advise how to remove myself from this email list.

See the List-Unsubscribe link, in the headers of every email you
receive from the list.

			regards, tom lane

---

From: James Pitchford <[email-masked]>
Date: Thu, 18 Nov 2021 12:59:12 -0500

Tom

There is no unsubscribe link (but there should be!).

I also tried the help link  in the headers but when trying to reset my email I get

Account error

This account cannot change password as it's connected to a third party login site.

A bit stuck.

Jim

> On 18 Nov 2021, at 12:50, Tom Lane <[email-masked]> wrote:
>

---

From: James Pitchford <[email-masked]>
Date: Thu, 18 Nov 2021 13:00:56 -0500

Ah, now found it.

I believe that link should be in the body of the email not hidden in the headers.

Jim

---

From: Tom Lane <[email-masked]>
Date: Thu, 18 Nov 2021 13:16:09 -0500

> I believe that link should be in the body of the email not hidden in the headers.

That's a fairly bad idea, actually.  Aside from it being a distracting
nuisance most of the time, people who include the entire body of a
message in their replies (which sadly is way too many people) would
be exposing the info needed to unsubscribe them.  Also, we can't
modify the bodies of messages as they pass through the list server
without breaking various anti-spam protocols.

			regards, tom lane