Received: from localhost (postgresql.org [64.49.215.8]) by postgresql.org (Postfix) with ESMTP id 033D3475CBC for ; Fri, 6 Sep 2002 22:35:52 -0400 (EDT) Received: from mta02ps.bigpond.com (mta02ps.bigpond.com [144.135.25.134]) by postgresql.org (Postfix) with ESMTP id B25FC475C26 for ; Fri, 6 Sep 2002 22:35:50 -0400 (EDT) Received: from nemeton.com.au ([144.135.25.84]) by mta02ps.bigpond.com (Netscape Messaging Server 4.15 mta02ps May 23 2002 23:53:28) with SMTP id H21R7S00.05B for ; Sat, 7 Sep 2002 12:35:52 +1000 Received: from 144.139.99.251 ([144.139.99.251]) by psmam06.mailsvc.email.bigpond.com(MailRouter V3.0n 110/20466369); 07 Sep 2002 12:35:48 Received: (qmail 23720 invoked from network); 7 Sep 2002 02:34:09 -0000 Received: from nemeton.com.au (203.8.3.33) by nemeton.com.au with SMTP; 7 Sep 2002 02:34:09 -0000 To: "Curtis Mortensen" Cc: pgsql-novice@postgresql.org Subject: Re: pg_restore error In-Reply-To: Message from "Curtis Mortensen" of "Fri, 06 Sep 2002 17:28:17 CST." Date: Sat, 07 Sep 2002 12:34:09 +1000 Message-ID: <23718.1031366049@nemeton.com.au> From: Giles Lean X-Virus-Scanned: by AMaViS new-20020517 X-Archive-Number: 200209/35 X-Sequence-Number: 4663 Hi Curtis, > thanks for the advice. i now have a different error. :( I suspected you would, but without knowing the commands you were using decided guessing would only be confusing! Only the archive formats from pg_dump are intended to be used with pg_restore. The default output can be restored by psql: $ pg_dump fubar > fubar.sql $ createdb fubar2 CREATE DATABASE $ psql fubar2 < fubar.sql You are now connected as new user giles. CREATE $ $ pg_dump --format=c fubar > fubar.dump $ createdb fubar2 CREATE DATABASE $ pg_restore --dbname=fubar2 < fubar.dump pg_restore: [archiver] WARNING: Data restoration may fail because existing triggers cannot be disabled (no superuser user name specified). This is only a problem when restoring into a database with already existing triggers. $ Regards, Giles