Subject: How to check completeness of installation

From: "Subramanian,Ramachandran" <[email-masked]>
Date: Thu, 19 Feb 2026 08:59:29 +0000

Hello,

   we are in a Situation where Linux boxes are delivered to us with postgres installed.  Our group cannot install or upgrade. We do not have root privileges.

Yesterday I found out pg_waldump bin file is missing and today I found out pg_archivecleanup is also missing.  I am new to postgres and do not have a complete list of executables that are expected to be present.

  1.  Is there any command or method with which we as DBAs can check for completeness of installation.
  2.  Is there any way with which we can install Postgress WITHOUT ROOT privileges.

I thank you in advance for your time and efforts in helping me.

LG
Ram

Freundliche Grüße

i. A. Ramachandran Subramanian
Zentralbereich Informationstechnologie

Alte Leipziger Lebensversicherung a.G.

Hallesche Krankenversicherung a.G.

Alte Leipziger Lebensversicherung a.G., Alte Leipziger-Platz 1, 61440 Oberursel
Vors. des Aufsichtsrats: Dr. Walter Botermann · Vorstand: Christoph Bohn (Vors.), Dr. Jürgen Bierbaum (stv. Vors.), Frank Kettnaker, Dr. Jochen Kriegmeier, Alexander Mayer, Christian Pape, Wiltrud Pekarek, Udo Wilcsek
Sitz Oberursel (Taunus) · Rechtsform VVaG · Amtsgericht Bad Homburg v. d. H. HRB 1583 · USt.-IdNr. DE 114106814

Hallesche Krankenversicherung a.G.,  Löffelstraße 34-38, 70597 Stuttgart
Vors. des Aufsichtsrats: Dr. Walter Botermann · Vorstand: Christoph Bohn (Vors.), Dr. Jürgen Bierbaum (stv. Vors.), Frank Kettnaker, Dr. Jochen Kriegmeier, Alexander Mayer, Christian Pape,
Wiltrud Pekarek, Udo Wilcsek
Sitz Stuttgart · Rechtsform VVaG · Amtsgericht Stuttgart HRB 2686 · USt.-IdNr. DE 147802285
Beiträge zu privaten Kranken- und Pflegekrankenversicherungen unterliegen nicht der Versicherungsteuer (§ 4 Nr. 5 VersStG) · Versicherungsleistungen sowie Umsätze aus Versicherungsvertreter-/Maklertätigkeiten sind umsatzsteuerfrei

Die Pflichtangaben der ALH Gruppe gemäß § 35a GmbHG bzw. § 80 AktG finden Sie hier: https://www.alte-leipziger.de/impressum 

______________________

ALH Gruppe
Alte Leipziger-Platz 1, 61440 Oberursel
Tel.: +49 (6171) 66-4882
Fax: +49 (6171) 66-800-4882
E-Mail: [email-masked]
www.alte-leipziger.de
www.hallesche.de

---

From: chris <[email-masked]>
Date: Thu, 19 Feb 2026 10:44:04 +0100

On Thu, Feb 19, 2026 at 08:59:29AM +0000, Subramanian,Ramachandran wrote:
> Hello,
> 
> we are in a Situation where Linux boxes are delivered to us with postgres installed.  
> Our group cannot install or upgrade. We do not have root privileges.
> 
> Yesterday I found out pg_waldump bin file is missing and today I found out 
> pg_archivecleanup is also missing.  I am new to postgres and do not have 
> a complete list of executables that are expected to be present.

Referring do Debian installations you should be able (unless it's explicitely prohibited) to use the 
debian package management to look around.

First you might want to look at the packages related to postgres installed:
	dpkg -l | grep postgres
then you can take a look at which files they contain, like:
	dpkg -L postgresql-server-dev-17

For RPM based distribution there are similar ways, just take a look at "man rpm".

>   1.  Is there any command or method with which we as DBAs can check for completeness of installation.

"completeness" is a vage description as there are numerous optional components.

>   2.  Is there any way with which we can install Postgress WITHOUT ROOT privileges.

You really should not do this, for several reasons. Just talk to the administration folks.

HTH, chris

---

From: "Subramanian,Ramachandran" <[email-masked]>
Date: Thu, 19 Feb 2026 09:54:46 +0000

Thank you so much for your reply. 

 The command dpkg does not work in our installation 

[postgres@lx90158 ~]$ dpkg
-bash: dpkg: command not found
[postgres@lx90158 ~]$

RPM seems to be too vast a topic for me to try a quick and dirty command. Need to read up on it. 

I will NOT attempt to install Postgres as non root.  Thank you for your suggestion. 

LG

Ram

Freundliche Grüße

 

______________________

ALH Gruppe

-----Ursprüngliche Nachricht-----
Von: chris <[email-masked]> 
Gesendet: Donnerstag, 19. Februar 2026 10:44
An: Subramanian,Ramachandran IT-md-db <[email-masked]>
Cc: [email-masked]
Betreff: Re: How to check completeness of installation

On Thu, Feb 19, 2026 at 08:59:29AM +0000, Subramanian,Ramachandran wrote:
> Yesterday I found out pg_waldump bin file is missing and today I found 
> out pg_archivecleanup is also missing.  I am new to postgres and do 
> not have a complete list of executables that are expected to be present.

Referring do Debian installations you should be able (unless it's explicitely prohibited) to use the debian package management to look around.

HTH, chris

---

From: chris <[email-masked]>
Date: Thu, 19 Feb 2026 11:25:50 +0100

> -bash: dpkg: command not found

The very first thing to do is: get informed about the Linux distribution you're working on:

	cat /etc/os-release

then use the appropriate tools.

> RPM seems to be too vast a topic for me to try a quick and dirty command. Need to read up on it. 

The two commands you would need (IIRC):

rpm -qa | grep -i postgres

rpm -qlp packagename

HTH, Chris

---

From: "Subramanian,Ramachandran" <[email-masked]>
Date: Thu, 19 Feb 2026 10:50:07 +0000

Hello 

  Thank you for your guidance. 

Our Linux Admin team said that they picked up a RHEL9 package with postgres ( I do not from where ), and this package possibly did not have the complete set of executables.

They also said that soon they will resolve the issue. 

The first two commands work , the third command  rpm -q | p package_name does not work  ( p unknown command ). 

😊 

LG

Ram 

[postgres@lx90158 ~]$ cat /etc/os-release
NAME="Red Hat Enterprise Linux"
VERSION="9.7 (Plow)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="9.7"
PLATFORM_ID="platform:el9"
PRETTY_NAME="Red Hat Enterprise Linux 9.7 (Plow)"
ANSI_COLOR="0;31"
LOGO="fedora-logo-icon"
CPE_NAME="cpe:/o:redhat:enterprise_linux:9::baseos"
HOME_URL="https://www.redhat.com/"
DOCUMENTATION_URL="https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/9"
BUG_REPORT_URL="https://issues.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 9"
REDHAT_BUGZILLA_PRODUCT_VERSION=9.7
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="9.7"
[postgres@lx90158 ~]$

[postgres@lx90158 ~]$ rpm -qa | grep -i postgres
postgresql-private-libs-16.10-1.module+el9.7.0+23477+80afd791.x86_64
postgresql-16.10-1.module+el9.7.0+23477+80afd791.x86_64
postgresql-server-16.10-1.module+el9.7.0+23477+80afd791.x86_64
[postgres@lx90158 ~]$

[postgres@lx90158 ~]$ rpm -q|p postgresql-server-16.10-1.module+el9.7.0+23477+80afd791.x86_64
-bash: p: command not found
rpm: no arguments given for query
[postgres@lx90158 ~]$

Freundliche Grüße

 

______________________

ALH Gruppe

-----Ursprüngliche Nachricht-----
Von: chris <[email-masked]> 
Gesendet: Donnerstag, 19. Februar 2026 11:26
An: Subramanian,Ramachandran IT-md-db <[email-masked]>; [email-masked]
Betreff: Re: How to check completeness of installation

	cat /etc/os-release

rpm -qlp packagename

HTH, Chris

---

From: chris <[email-masked]>
Date: Thu, 19 Feb 2026 12:03:53 +0100

On Thu, Feb 19, 2026 at 10:50:07AM +0000, Subramanian,Ramachandran wrote:
> Our Linux Admin team said that they picked up a RHEL9 package with postgres ( I do not from where ), 
> and this package possibly did not have the complete set of executables.

there are RPM from postgresql.org:
https://www.postgresql.org/download/linux/redhat/

I would expect them to be complete (maybe just for comparison)

> They also said that soon they will resolve the issue. 

Nice guys :-)

> The first two commands work , the third command  rpm -q | p package_name does not work  ( p unknown command ). 

it's rather "minus qu _ell_ pee" than "minus qu _pipe_ pee"

> NAME="Red Hat Enterprise Linux"

so it's Red Hat Enterprise Linux Version 9.7
which uses "rpm" as package manager.

HTH, Chris

---

From: Tom Lane <[email-masked]>
Date: Thu, 19 Feb 2026 09:54:15 -0500

> You really should not do this, for several reasons.

Why not?  People do that all the time if they are building from
source:

https://www.postgresql.org/docs/current/installation.html

I will grant that there's some security advantage to installing the
executables under an ownership account that's different from the
one used to run the server.  But it doesn't follow that the owning
account has to be root.

			regards, tom lane

---

From: chris <[email-masked]>
Date: Thu, 19 Feb 2026 16:12:13 +0100

On Thu, Feb 19, 2026 at 09:54:15AM -0500, Tom Lane wrote:
> Why not?  

besides all technical discussions:
- compliance 
- regulations
- house rules
- administration 
- maintainability for years to come
- ...

The life of software does not end when the compiler stops without errors 
in fact it's its beginning.

---

From: Laurenz Albe <[email-masked]>
Date: Thu, 19 Feb 2026 16:51:39 +0100

On Thu, 2026-02-19 at 10:50 +0000, Subramanian,Ramachandran wrote:
> The first two commands work

So you are using an RPM-based distribution.

To list the installed packages, run

  rpm -qa | grep postgresql

They should include the "server" package and the "contrib" package.

If you cannot "find" some PostgreSQL commands like "pg_archivecleanup",
it is also conceivable that they are not on your PATH, and that you need
to invoke them with their absolute path, like

  /usr/pgsql-18/bin/pg_archivecleanup

(This example assumes PostgreSQL v18.)

Yours,
Laurenz Albe

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 19 Feb 2026 08:52:20 -0700

On Thu, Feb 19, 2026 at 1:59 AM Subramanian,Ramachandran <
[email-masked]> wrote:

> I am new to postgres and do not have a complete list of executables that
> are expected to be present.
>
>
>
Read the documentation for the version you have installed.  It includes
reference pages for the various binaries that get produced.

David J.

p.s., maybe consider not including that signature for emails to a public
mailing list...especially when you reply without trimming out unnecessary
content.  We prefer inline or bottom-posting on these lists.