Subject: Maintenance solutions

From: Brian Nielsen <[email-masked]>
Date: Wed, 15 Jan 2020 10:19:05 +0100

Hi!

First post here for me. I wrote the question below on StackOverflow but 
it wasnt allowed and I was directed to these mailinglists.

 From Stack:
------
Im currently an MSSQL DBA and have been for soon 2 decades. However, Im 
very curious about PostgreSQL and want to learn more. I have installed 
it etc but coming from MSSQL where the community is awesome I fail to 
find a good community for PG where I can ask these questions. Im used to 
free scriptpackages on MSSQL like Ola Hallengrens backup solution or 
Adam Machanics sp_whoisactive/Brent Ozar sp_blitz.

Im guessing (and hoping) that any such tools/scripts are available for 
PG but I fail to find it. Can anyone point me to either a nice tool like 
the ones mentioned above or a PG community that can help me out, or even 
better, to both?
------

Big thanks in advance!

Kind regards,
Brian

---

From: Lætitia Avrot <[email-masked]>
Date: Wed, 15 Jan 2020 10:28:23 +0100

Hi Brian,

Welcome to Postgres community!
If you want to interact with the community, this mailing list is a great
starting point. However, if you'd rather have more interactivity, may I
suggest:

   - IRC (https://www.postgresql.org/community/irc/)
   - Slack (https://postgres-slack.herokuapp.com/)
   - Telegram (https://tgram.io/group/2290/pg_sql)
   - Twitter (a lot of people watch the #PostgreSQL hashtag, just ask your
   question and you should have answers)
   - Events (IRL meeting with community is so great, you'l find a list of
   local user groups and community events all around the world here:
   https://www.postgresql.org/community/

About free scripts and tool, you will find so many of them that your main
problem will be to choose the one you want to choose from :-D

Have a nice day,

Lætitia

-- 
*Paper doesn’t grow on trees. Please print responsibly.*

---

From: Brian Nielsen <[email-masked]>
Date: Wed, 15 Jan 2020 12:26:58 +0100

Hi! 

Thanks for you answer. I have now joined Slack (used it before).  

Which backup-scripts and indexmaintenance-scripts are you guys using in
your prod-environments? 

Kind regards, 

Brian 

2020-01-15 10:28 skrev Lætitia Avrot:

> If you want to interact with the community, this mailing list is a great starting point. However, if you'd rather have more interactivity, may I suggest:
> 
> * IRC (https://www.postgresql.org/community/irc/)
> * Slack (https://postgres-slack.herokuapp.com/)
> * Telegram (https://tgram.io/group/2290/pg_sql)
> * Twitter (a lot of people watch the #PostgreSQL hashtag, just ask your question and you should have answers)
> * Events (IRL meeting with community is so great, you'l find a list of local user groups and community events all around the world here: https://www.postgresql.org/community/
> 
> About free scripts and tool, you will find so many of them that your main problem will be to choose the one you want to choose from :-D
> 
> Have a nice day,
> 
> Lætitia 
> 
> _Paper doesn't grow on trees. Please print responsibly._

---

From: "Ireneusz Pluta/wp.pl" <[email-masked]>
Date: Wed, 15 Jan 2020 13:59:51 +0100

W dniu 2020-01-15 o 10:19, Brian Nielsen pisze:
> Im currently an MSSQL DBA and have been for soon 2 decades. However, Im very curious about 
> PostgreSQL and want to learn more. I have installed it etc but coming from MSSQL where the 
> community is awesome I fail to find a good community for PG where I can ask these questions. Im 
> used to free scriptpackages on MSSQL like Ola Hallengrens backup solution or Adam Machanics 
> sp_whoisactive/Brent Ozar sp_blitz.
>
> Im guessing (and hoping) that any such tools/scripts are available for PG but I fail to find it. 
> Can anyone point me to either a nice tool like the ones mentioned above or a PG community that can 
> help me out, or even better, to both?
>
Hi Brian,

maybe it is not a right anwer to your particular question, but as far as "tooling" is concerned, you 
as an MSSQL guy might be interested in reading the following blog post 
https://rob.conery.io/2019/03/04/postgresql-tools-for-the-visually-inclined/ and some other ones 
linked from there.

---

From: Lætitia Avrot <[email-masked]>
Date: Wed, 15 Jan 2020 14:05:37 +0100

Hi Brian,

You will find good scripts here:
- https://github.com/pgexperts/pgx_scripts
- https://github.com/dataegret/pg-utils
- https://wiki.postgresql.org/wiki/Index_Maintenance

For the backup, you have several tools in the community. The tool provided
by PostgreSQL core is too raw IMHO. It focuses on backups and I'd rather
have a way to restore my data than having a way to backup my data.
Here is a list of some open source backup tools:
- pg_basebackup (https://www.postgresql.org/docs/12/app-pgbasebackup.html)
- barman (https://www.pgbarman.org/)
- pgbackrest (https://pgbackrest.org/)
- probackup (https://postgrespro.com/products/extensions/pg_probackup)

I strongly advise not to develop your own scripts to perform backup and
recovery, because there are so many ways this could go wrong...

Have a nice day,

Lætitia

Le mer. 15 janv. 2020 à 12:27, Brian Nielsen <[email-masked]> a écrit :

>    - Twitter (a lot of people watch the #PostgreSQL hashtag, just ask
>    your question and you should have answers)
> *Paper doesn't grow on trees. Please print responsibly.*
>
>
>