Subject: Need help with moving test cases in extension folder

From: mahendrakar s <[email-masked]>
Date: Thu, 9 Jun 2022 22:09:11 +0530

Hi Team,

When we run `make check` inside the contrib/<extension> folder, it ALWAYS
looks for folder `sql` for testscripts.
i.e: contrib/<extension>/sql -->[1].

I have a requirement to move test related folders to a different folder(sub
directory of extension),
i.e contrib/<extension>/<testsubdir>/sql -->[2].

Is there a way to tell `make check` to look at [2] instead of [1]? Are
there any flags to configure Makefile? Can you please let me know.
Appreciate your help.

Thanks,
Mahendrakar.

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 10 Jun 2022 03:59:16 +0200

On Thu, 2022-06-09 at 22:09 +0530, mahendrakar s wrote:
> When we run `make check` inside the contrib/<extension> folder, it ALWAYS looks for folder `sql` for testscripts. 
> I have a requirement to move test related folders to a different folder(sub directory of extension),
> Is there a way to tell `make check` to look at [2] instead of [1]? Are there any flags to configure Makefile? Can you please let me know.
> Appreciate your help.

No, the location of the regression tests is hard-coded.

You can add NO_INSTALLCHECK to the Makefile to skip the automatic execution
of the regression tests and run your own later in a different way.

Yours,
Laurenz Albe

PS: I have the feeling that surprisingly, the questions on the -novice list are
almost never novice questions.  I wonder why.