Subject: Just switched to Mac - Postgres.app or Homebrew or some other distribution?

From: Simon Connah <[email-masked]>
Date: Sun, 16 Oct 2022 16:23:13 +0000

I've been playing around with Postgres.app, and while it works well, it does hide some of the server-side stuff and configuration.

What is the best way to run PostgreSQL on the Mac that mirrors the Linux workflow? I'm not doing anything too complex.

Thank you.

---

From: Gerald Cheves <[email-masked]>
Date: Sun, 16 Oct 2022 13:39:34 -0400

> What is the best way to run PostgreSQL on the Mac that mirrors the Linux workflow? I'm not doing anything too complex.

I used a download from Enterprisedb. Make sure you add the location of 
the  installation to the PATH because Macs come with a partial 
installation of Postgres pre-installed and you want your installation to 
be in the path so your shell commands and front-end commands (e.g., 
psql, pgAdmin, LibreOffice, etc.) will work properly.

- G

-- 
siamo arrivati sani e salvi

---

From: Simon Connah <[email-masked]>
Date: Sun, 16 Oct 2022 17:50:57 +0000

Thanks. I'll look into that.

As for the Docker suggestion, I should probably spend some time learning how to use it correctly, but for the time being, I'm going down this route while I get everything up and running, and I can worry about Docker later.

Simon.

------- Original Message -------
On Sunday, October 16th, 2022 at 18:39, Gerald Cheves <[email-masked]> wrote:

---

From: Alex Theodossis <[email-masked]>
Date: Sun, 16 Oct 2022 16:04:18 -0400

Hi,

Not sure why you want to run the database from a mac? Just being curious

Much better running from a server? You can get a cloud server with your 
choice of OS (I suggest Fedora or Arch) from linode for $20/month to do 
your testing? It comes with 80GB data storage. If your data needs are 
substantial and on prem server with zfs (again arch as the base system) 
will be more suitable.

Macs are great (I have been a user for decades), but they 'cripple' 
Unix, so you don't get the full advantage.

Alex Theodossis
[email-masked]

On 10/16/22 13:39, Gerald Cheves wrote:
>> I've been playing around with Postgres.app, and while it works well, 
>> it does hide some of the server-side stuff and configuration.
>>
>> What is the best way to run PostgreSQL on the Mac that mirrors the 
>> Linux workflow? I'm not doing anything too complex.
>>
>> Thank you.
>
> installation of Postgres pre-installed and you want your installation 
> to be in the path so your shell commands and front-end commands (e.g.,

---

From: "Jim Chanco Jr." <[email-masked]>
Date: Sun, 16 Oct 2022 18:31:31 -0400

Hi, there.

Also curious to know what your use case might be. If it's just to test
things as needed, pgenv is good for that. The tool can be found in git
(theory/pgenv).

Kind regards,

Jim

---

From: John DeSoi <[email-masked]>
Date: Mon, 17 Oct 2022 00:38:58 +0000

> On Oct 16, 2022, at 11:23 AM, Simon Connah <[email-masked]> wrote:
> 

Hombebrew is a good option. I'm using it in development and production without any problems. I previously used CentOS, and don't find the workflow to be much different.

John DeSoi, Ph.D.

---

From: Simon Connah <[email-masked]>
Date: Tue, 18 Oct 2022 11:55:00 +0000

------- Original Message -------
On Sunday, October 16th, 2022 at 21:04, Alex Theodossis <[email-masked]> wrote:

Hi,

I'm just doing basic web development. I could use Linode (they already host a couple of blogs for me), but since I'm still playing around with PostgreSQL, I'd rather just do it on my Mac for the time being.