Subject: ALTER DEFAULT PRIVILEGES

From: Fredrik Gustavsson <[email-masked]>
Date: Wed, 30 Mar 2022 11:00:55 +0000

HelloTeam

I have a question on how to  revoke privileges granted by another user
\ddp shows (Swedish names)
       Owner        |         Schema         |   Type   |             Access privileges
--------------------+------------------------+----------+-------------------------------------------
sbkrojo            | kom_enhetskatalogen_v1 | table    | leveransdata_r=r/sbkrojo                 +
                    |                        |                                    | leveransdata_w=arwdDxt/sbkrojo           +
                    |                        |                                    | ponf_r=r/sbkrojo                         +
                    |                        |                                   | tk_r=r/sbkrojo

The two last lines is the ones I whish to get rid of
I tried the following sql statement
ALTER DEFAULT PRIVILEGES IN SCHEMA  kom_enhetskatalogen_v1 revoke all on tables from tk_r
but the grant is still present
Also tried to grant myown id to role sbkrojo,;
GRANT SBKROJO O MYID WITH ADMIN OPTION;
But I'm still not able to remove the privileges from tk_r.
Is there a way to achieve this ?
Sbkrojo is an old user no longer with our organization but I don't want to change the pwd for it since there are bach jobs running under the same id.
We are running
postgres (PostgreSQL) 9.5.2 on windows server 2012.
Thanks for your support

Best regards

Vänliga hälsningar

Fredrik Gustavsson

Systemadministratör
Geodataavdelningen

GÖTEBORGS STAD
Stadsbyggnadskontoret

Telefon: 031-36880801
E-post: [email-masked]

Postadress: Box 2554, 403 17 Göteborg
Besök: Köpmansgatan 20
www.goteborg.se<http://www.goteborg.se/>

Så här behandlar stadsbyggnadskontoret dina personuppgifter<https://goteborg.se/wps/portal?uri=gbglnk%3a20185816278319>

---

From: Mark Wallace <[email-masked]>
Date: Thu, 31 Mar 2022 04:48:42 -0400

One revokes privileges only with the REVOKE command.

See: PostgreSQL 9.5 documentation, pages 1642-1645.

> On Mar 30, 2022, at 07:00, Fredrik Gustavsson <[email-masked] <mailto:[email-masked]>> wrote:
> 
> HelloTeam
>  
> But I’m still not able to remove the privileges from tk_r.
> Sbkrojo is an old user no longer with our organization but I don’t want to change the pwd for it since there are bach jobs running under the same id.
> We are running
> E-post: [email-masked] <mailto:[email-masked]>
> 
> www.goteborg.se <http://www.goteborg.se/>
> 
> Så här behandlar stadsbyggnadskontoret dina personuppgifter <https://goteborg.se/wps/portal?uri=gbglnk%3a20185816278319>