Subject: following install of Postgres on Centos 7, how to install PGAdmin

From: "James, David (RIS-SUT)" <[email-masked]>
Date: Tue, 27 Jun 2023 09:42:59 +0000

Hello All

This is my first ever post here.
I have successfully installed Postgres on our Centos 7 server. I would now like to install PGAdmin so I can use via my Windows machine - do I follow the notes here ? :

https://www.pgadmin.org/download/pgadmin-4-rpm/

Thanks.

________________________________
The information contained in this e-mail message is intended only for the personal and confidential use of the recipient(s) named above. This message may be an attorney-client communication and/or work product and as such is privileged and confidential. If the reader of this message is not the intended recipient or an agent responsible for delivering it to the intended recipient, you are hereby notified that you have received this document in error and that any review, dissemination, distribution, or copying of this message is strictly prohibited. If you have received this communication in error, please notify us immediately by e-mail, and delete the original message.

---

From: Rajiv Harlalka <[email-masked]>
Date: Tue, 27 Jun 2023 17:54:19 +0530

Since you'll access the Server on the Windows machine, PGAdmin needs to be
installed on the Windows machine. Only necessary configurational changes in
pg_hba.conf and postgresql.conf would be needed as per your settings for
PGAdmin to be able to connect to the server on the CentOS server.

Regards,
Rajiv

On Tue, Jun 27, 2023 at 3:13 PM James, David (RIS-SUT) <
[email-masked]> wrote:

> I have successfully installed Postgres on our Centos 7 server. I would now
> like to install PGAdmin so I can use via my Windows machine – do I follow
> the notes here ? :
>
>
>
> ------------------------------
> The information contained in this e-mail message is intended only for the
> personal and confidential use of the recipient(s) named above. This message
> may be an attorney-client communication and/or work product and as such is
> privileged and confidential. If the reader of this message is not the
> intended recipient or an agent responsible for delivering it to the
> intended recipient, you are hereby notified that you have received this
> document in error and that any review, dissemination, distribution, or
> copying of this message is strictly prohibited. If you have received this
> communication in error, please notify us immediately by e-mail, and delete
> the original message.
>

---

From: "James, David (RIS-SUT)" <[email-masked]>
Date: Tue, 27 Jun 2023 12:37:34 +0000

many thanks for your reply – are you saying that although I have Postgres running on Linux, I only need to choose the Windows option for installing PGAdmin?

So, I should start from here ? https://www.pgadmin.org/download/pgadmin-4-windows/

If you know of any documentation that might accompany this?

Thank you again.

DJ.

From: Rajiv Harlalka <[email-masked]>
Sent: Tuesday, June 27, 2023 1:24 PM
To: James, David (RIS-SUT) <[email-masked]>
Cc: [email-masked]
Subject: Re: following install of Postgres on Centos 7, how to install PGAdmin

You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification>

*** External email: use caution ***

Since you'll access the Server on the Windows machine, PGAdmin needs to be installed on the Windows machine. Only necessary configurational changes in pg_hba.conf and postgresql.conf would be needed as per your settings for PGAdmin to be able to connect to the server on the CentOS server.

Regards,
Rajiv

On Tue, Jun 27, 2023 at 3:13 PM James, David (RIS-SUT) <[email-masked]<mailto:[email-masked]>> wrote:
Hello All

This is my first ever post here.
I have successfully installed Postgres on our Centos 7 server. I would now like to install PGAdmin so I can use via my Windows machine – do I follow the notes here ? :

Thanks.

---

From: Nicolas Mitchell <[email-masked]>
Date: Tue, 27 Jun 2023 16:28:23 +0100

There's a link to the documentation on that page - latest docs.

Download and install pgadmin on your Windows machine. Assuming SSH is 
enabled on the pgsql machine...

Next you'll want to edit pg_hba.conf (on your pgsql server) to include a 
line similar to this:

host   all   all   127.0.0.1/32   scram-sha-256

Next you'll need to register the server in pgadmin.

Under Connection, the host name/address should be localhost
If you're managing all databases on the server, leave the user/database 
information as is. i.e. connect as postgres, connect to postgres.

You can enter your postgres password here and opt to have it saved.

Under SSH Tunnel, enter the pgsql server's hostname and the username 
with which you can connect to it via SSH.

Save the connection and you should be prompted for at least your SSH 
password, possibly the postgres user password too.

If you have not set a password for the postgres user, you must do that 
first.

If you do not have admin rights on the Windows PC you may not be able to 
follow through with this because an exception has to be added to the 
Windows firewall, which may, depending on local policy, be restricted to 
administrators.

Nic

---

From: "James, David (RIS-SUT)" <[email-masked]>
Date: Tue, 27 Jun 2023 15:48:24 +0000

Yes thanks …. I am an Oracle DBA and if I want instructions then I just go to the Oracle site and I can find them

It seems here people (helpfully) give me ideas but no one is pointing me to a document that I can follow. Yes, I am doing this using blogs / jumping around online – but is there not a standard set of books for this kind of basic thing?

If anyone can reference me a document that shows how to install PGAdmin and make it connect to the db that would be great thanks.

Kind Regards,
David James.
Oracle DBA.

From: Rajiv Harlalka <[email-masked]>
Sent: Tuesday, June 27, 2023 4:31 PM
To: James, David (RIS-SUT) <[email-masked]>
Subject: Re: following install of Postgres on Centos 7, how to install PGAdmin

According to your specifications you want to have your PostgreSQL server (which is on CentOS), accesible from a Windows Machine.

Required to do:
- setup Postgresql server on CentOS with all necessary settings and configurations. ( A simple good result would point to good enough blogs for this)
- install PGAdmin on Windows and connect to the PostgreS cluster using the TCP/IP connections.

On Tue, 27 Jun 2023, 8:54 pm James, David (RIS-SUT), <[email-masked]<mailto:[email-masked]>> wrote:
My apologies.
What I have done is install Postgres on my Linux server, using rpms etc

Now I want to install / connect PGAdmin so that I can administer it.

The database is on the Linux server not windows.

So should I go back to trying to install PGAdmin on the Linux machine?

Thanks.

Kind Regards,
David James.
Oracle DBA.

From: Rajiv Harlalka <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 27, 2023 4:03 PM
To: James, David (RIS-SUT) <[email-masked]<mailto:[email-masked]>>
Subject: Re: following install of Postgres on Centos 7, how to install PGAdmin

On Tue, 27 Jun 2023, 8:30 pm James, David (RIS-SUT), <[email-masked]<mailto:[email-masked]>> wrote:
Thanks – that link shows how to install PGAdmin on the Linux server when I thought I just needed it for windows
As per you said , you need to access the server on a windows machine. In that case you need to install PGadmin on windows.
I am really confused about how to do this – why is there no documentation available?
Documentation for? PG docs have almost everything you'll need