Subject: Asking for existence of a GUI frame work similar to Oracle APEX for PostgreSQL and others

From: Dionisis Kontominas <[email-masked]>
Date: Fri, 21 Oct 2022 19:14:09 +0200

Hello all,

    This is my fist email and I ask for leniency on the response. I am
quite new to PostgreSQL, and had my first taste of a Windows version. My
background is Oracle and I have some questions. I will also post in the
admin list.

   1. What is the best Linux server for the PostgresQL in your opinion?
   Ubuntu Server, Redhat, other?
   2. Is there a low-cost or free low code development tool / framework
   similar to Oracle APEX for PostgreSQL?
   3. In continuation to the previous question, has anyone attempted to
   combine Oracle APEX with PostgreSQL using REST, i.e. something like pgREST
   or similar / alternative and what are the experiences?

Thanks In advance!

Kindest regards,
Dionisis Kontominas

---

From: Dionisis Kontominas <[email-masked]>
Date: Fri, 21 Oct 2022 19:16:40 +0200

Subject:

Hello all,

Thanks In advance!

Kindest regards,
Dionysis Kontominas

---

From: Laurenz Albe <[email-masked]>
Date: Sat, 22 Oct 2022 05:48:19 +0200

On Fri, 2022-10-21 at 19:16 +0200, Dionisis Kontominas wrote:
> My background is Oracle and I have some questions. I will also post in the admin list.

You probably didn't know, but you should avoid posting the same e-mail to several
lists at the same time.

>    1. What is the best Linux server for the PostgresQL in your opinion? Ubuntu Server, Redhat, other?

It really doesn't matter which Linux distribution you are using.
If you want to use binary installation packages, use one of the distributions for which
the PostgreSQL web site offers binary packages.  Other than that, use the one that you
like best.

>    2. Is there a low-cost or free low code development tool / framework similar to Oracle APEX for PostgreSQL?

You could have a look at CYPEX: https://www.cybertec-postgresql.com/en/products/cypex/
Full disclosure: I work for that company.

Yours,
Laurenz Albe

---

From: Dionisis Kontominas <[email-masked]>
Date: Sat, 22 Oct 2022 09:45:15 +0200

Thank you Laurent; I was not aware and this was my first ever post. I am
sorry about the inconvenience that it might have caused.

   1. I was thinking about Ubuntu; In the site it says that in
   PostgreSQL Apt Repository it supports  impish (21.10) as the latest version
   (https://www.postgresql.org/download/linux/ubuntu/), but in the news (
   https://wiki.postgresql.org/wiki/Apt) says

   - 2022-07-24: Ubuntu impish (21.10) is no longer supported
      - 2022-02-16: Ubuntu jammy (22.04) added, hirsute (21.04) is no
      longer supported

  clearly indicating that the latest version to be used is 22.04
Which of the two is the correct information?  It seems also that PostgreSQL
15 is not yet in the repository; at least not mentioned in the news section.

2. I will have a look.at it

Thank you for the time for your response.

Yours,.
Dionisis Kontominas

On Sat, 22 Oct 2022 at 05:48, Laurenz Albe <[email-masked]> wrote:

> You could have a look at CYPEX:
> https://www.cybertec-postgresql.com/en/products/cypex/