Subject: Reset date for Cumulative Statistics System when not in table

From: blockdump <[email-masked]>
Date: Mon, 26 Feb 2024 14:47:38 +0100

Hello,
I am new to Postgres and started reading about the The Cumulative
Statistics System.
https://www.postgresql.org/docs/current/monitoring-stats.html#MONITORING-PG-STATIO-ALL-TABLES-VIEW

When I came across pg_statio_all_tables I was wondering what is the
reference date for the counters like (heap_blks_read, heap_blks_hit ... )
This table does not have a stats_reset column like others.
So are this numbers accumulating from the creation of the table or since
the startup of the cluster ?

Maybe someone can drop me a line.

cheers
Guenter

---

From: Laurenz Albe <[email-masked]>
Date: Mon, 26 Feb 2024 16:40:53 +0100

On Mon, 2024-02-26 at 14:47 +0100, blockdump wrote:
> I am new to Postgres and started reading about the The Cumulative Statistics System. 
> When I came across pg_statio_all_tables I was wondering what is the reference date for the
> counters like (heap_blks_read, heap_blks_hit ... ) This table does not have a stats_reset column like others. 
> So are this numbers accumulating from the creation of the table or since the startup of the cluster ?
> 

Statistics survive a restart, but not a crash, so the statistics are
collected since the table was created, the latest crash happened or the
statistics were reset; whatever happened last.

Unfurtunately there is no way to find out the time when that happened.

Yours,
Laurenz Albe

---

From: blockdump <[email-masked]>
Date: Mon, 26 Feb 2024 17:52:24 +0100

Thank you so much for the info!

On Mon, Feb 26, 2024, 16:40 Laurenz Albe <[email-masked]> wrote:

> reference date for the