Subject: switch between async to sync automatically

From: Sacheen Birhade <[email-masked]>
Date: Thu, 4 Aug 2022 07:40:56 +0000

Hi All,

Can my streaming replication switch between async to sync automatically depending upon bandwidth? If bandwith/replication link is very healthy, then I want async replication otherwise sync replication. It should switch between sync to async.
You help is appreciated.

Thanks,
Sacheen Birhade

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 11 Aug 2022 21:09:31 -0400

On Thu, Aug  4, 2022 at 07:40:56AM +0000, Sacheen Birhade wrote:
> Hi All,
> 
>  
> 
> Can my streaming replication switch between async to sync automatically
> depending upon bandwidth? If bandwith/replication link is very healthy, then I
> want async replication otherwise sync replication. It should switch between
> sync to async.

No.  We have discussed the option of going from sync to async if the
standby stops responding but never agreed on a safe API for this.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Indecision is a decision.  Inaction is an action.  Mark Batterson