Subject: newbie pointers for development

From: Ankit Pandey <[email-masked]>
Date: Tue, 1 Nov 2022 18:05:25 +0530

Hello,

I am new to pg hacking and would need some pointers to contribute. I looked
into the todo list but it is filled more with feature enhancements (will
take some time to get there). If I could get some pointers for beginner
friendly issues/bugs, I would be glad.
Note: I am able to step through (via gdb) the whole backend process while
it runs queries, so I have some initial setup to get going.

Thanks,
Ankit

---

From: Laurenz Albe <[email-masked]>
Date: Tue, 01 Nov 2022 14:47:24 +0100

On Tue, 2022-11-01 at 18:05 +0530, Ankit Pandey wrote:
> I am new to pg hacking and would need some pointers to contribute. I looked into the todo
> list but it is filled more with feature enhancements (will take some time to get there).
> If I could get some pointers for beginner friendly issues/bugs, I would be glad.
> Note: I am able to step through (via gdb) the whole backend process while it runs queries,
> so I have some initial setup to get going.

The canonical starting point is here:
https://wiki.postgresql.org/wiki/So,_you_want_to_be_a_developer%3F

The king's way to learning the ropes is reviewing patches in the current
commitfest.  That will familiarize you with the conversation style on the
mailing lists, with the development cycle and with the code.

Yours,
Laurenz Albe

---

From: Ankit Pandey <[email-masked]>
Date: Wed, 2 Nov 2022 12:21:45 +0530

>  Lesson #1: reply to the list.
Point noted

> Yes, you need to be subscribed to the hackers list, because that's where
you submit
> patches and reviews.
Subscribed and looking at various patches.

> https://wiki.postgresql.org/wiki/So,_you_want_to_be_a_developer%3F

I have also gone through this but still, I am not exactly clear where to
start (assuming I can run, build, debug and play with git).

Also another question, which email client does everyone use (mostly) for
communication?

Thanks,
Ankit

On Wed, Nov 2, 2022 at 11:35 AM Laurenz Albe <[email-masked]>
wrote:

> Dear Ankit!
> > > commitfest.
> > Thanks Laurenz, will this involve watching patches by subscribing to
> [email-masked] mailing list or something else?
>
> Lesson #1: reply to the list.
>
> Yes, you need to be subscribed to the hackers list, because that's where
> you submit
> patches and reviews.
>
> Yours,
> Laurenz Albe
> --
> +43-670-6056265
> CYBERTEC PostgreSQL International GmbH
> Römerstraße 19, 2752 Wöllersdorf
> Web: https://www.cybertec-postgresql.com
>

---

From: Ankit Pandey <[email-masked]>
Date: Wed, 2 Nov 2022 14:54:24 +0530

On Wed, 2 Nov, 2022, 2:45 pm Bear, <[email-masked]> wrote:
> remove

Sorry? I don't get you.

Thanks,
Ankit

On Wed, 2 Nov, 2022, 2:45 pm Bear, <[email-masked]> wrote:

> remove
> On 02-Nov-22 01:51, Ankit Pandey wrote:
>

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 02 Nov 2022 12:00:28 +0100

On Wed, 2022-11-02 at 12:21 +0530, Ankit Pandey wrote:
> I have also gone through this but still, I am not exactly clear where to start
> (assuming I can run, build, debug and play with git).

Grab a patch from https://commitfest.postgresql.org/40/ that is simple enough,
try to apply it to Git head and see if it builds and passes the regression tests.
Then try to break it :^)
Read the code to see what the patch does.
It is best to start with a patch that touches an area of PostgreSQL that you understand well.

> Also another question, which email client does everyone use (mostly) for communication?

I use Eclipse (default on Gnome), but I guess everybody has their own preferences.

By the way, thanks for your willingness to help!

Yours,
Laurenz Albe

---

From: Ankit Pandey <[email-masked]>
Date: Wed, 2 Nov 2022 17:18:42 +0530

>try to apply it to Git head and see if it builds and passes the regression
tests.

Sounds like a plan, really appreciate this. I will try and see how it goes.

> I use Eclipse (default on Gnome), but I guess everybody has their own
preferences.

Hmm, I am not able to find this on Ubuntu, default here is thunderbird.
Asking this because it is a bit difficult to reply via webmail.

Thanks,
Ankit

On Wed, Nov 2, 2022 at 4:30 PM Laurenz Albe <[email-masked]>
wrote:

> start