Subject: I installed PostgreSQL 16 from the offical Fedora 39 repos - need PostGIS

From: Simon Connah <[email-masked]>
Date: Mon, 13 Nov 2023 05:52:32 +0000

Hi,

I installed PostgreSQL 16 on a Fedora 39 server using these instructions:

https://www.postgresql.org/download/linux/redhat/

and it is working fine but I need to add PostGIS to this install. Is there another repo that provides this on Fedora 39 for the latest version of PostgreSQL?

Thank you.

Simon.

---

From: Laurenz Albe <[email-masked]>
Date: Mon, 13 Nov 2023 07:01:06 +0100

On Mon, 2023-11-13 at 05:52 +0000, Simon Connah wrote:
> and it is working fine but I need to add PostGIS to this install. Is there
> another repo that provides this on Fedora 39 for the latest version of PostgreSQL?

It is in the same repository.

I can see the files in
https://download.postgresql.org/pub/repos/yum/16/fedora/fedora-39-x86_64/

If you experience trouble with

  sudo dnf install postgis34_16

please report that to the pgsql-pkg-yum mailing list.

Yours,
Laurenz Albe

---

From: Simon Connah <[email-masked]>
Date: Mon, 13 Nov 2023 07:05:39 +0000

> please report that to the pgsql-pkg-yum mailing list.

Sorry. I forgot to reply all.

Thank you. One mistake I made in the above post is that it wasn't Fedora 39 it was Rocky Linux 9. I've sent a message to the Yum mailing list anyway.

Simon.