Subject: Update PostgreSQL 11-odbc-12.01.0000-1PGDG.rhel7.x86_64

From: "Soliman, Abdelrahman" <[email-masked]>
Date: Thu, 23 Jan 2025 17:18:58 +0000

Can I please get some assistance in updating this package. The current version is encountering a vulnerability
rpm -qi postgresql11-odbc
Name        : postgresql11-odbc
Version     : 12.01.0000
Release     : 1PGDG.rhel7
Architecture: x86_64
Install Date: Thu 21 Oct 2021 10:46:30 PM EDT
Group       : Unspecified
Size        : 1060881
License     : LGPLv2
Signature   : DSA/SHA1, Mon 27 Jan 2020 03:13:46 AM EST, Key ID 1f16d2e1442df0f8
Source RPM  : postgresql11-odbc-12.01.0000-1PGDG.rhel7.src.rpm
Build Date  : Mon 27 Jan 2020 03:13:41 AM EST
Build Host  : koji-centos7-x86-64-pgbuild
Relocations : (not relocatable)
Vendor      : PostgreSQL Global Development Group
URL         : https://odbc.postgresql.org/
Summary     : PostgreSQL ODBC driver
Description :
This package includes the driver needed for applications to access a
PostgreSQL system via ODBC (Open Database Connectivity).

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 24 Jan 2025 08:31:27 +0300

Hi,

> rpm -qi postgresql11-odbc

You are using and EoLed distro and EoLed PostgreSQL version. PGDG
repositories don't support these.

However you can always download an SRPM and build the package yourself:

https://download.postgresql.org/pub/repos/yum/srpms/17/redhat/rhel-8-x86_64/postgresql17-odbc-17.00.0004-1PGDG.rhel8.src.rpm

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR