Subject: 32 bit DLL's

From: Dave Cramer <[email-masked]>
Date: Thu, 12 Oct 2023 09:17:28 -0400

I noticed that the project currently provides 32bit DLL's in the release.

Is anyone using them?

Dave Cramer

---

From: Kamil ADEM <[email-masked]>
Date: Thu, 12 Oct 2023 14:06:43 +0000

Yes, Dave.
We are using them. We have a 32-bit application that we are migrating from MSSQL.

Kamil Adem
Aqvila Software

From: Dave Cramer <[email-masked]>
Sent: Thursday, October 12, 2023 4:17 PM
To: PostgreSQL mailing lists <[email-masked]>
Subject: 32 bit DLL's

Is anyone using them?

Dave Cramer

---

From: Jon Raiford <[email-masked]>
Date: Thu, 12 Oct 2023 15:35:07 +0000

Yes, we are using them as well. Please do not abandon 32-bits.

Jon

(sorry for the duplicate email – I forgot to reply all)

From: Dave Cramer <[email-masked]>
Date: Thursday, October 12, 2023 at 9:26 AM
To: PostgreSQL mailing lists <[email-masked]>
Subject: 32 bit DLL's
I noticed that the project currently provides 32bit DLL's in the release.

Is anyone using them?

Dave Cramer

---

From: "M. Neumann - Prisma Computer" <[email-masked]>
Date: Thu, 12 Oct 2023 17:57:15 +0200

Yes, we are using them inside a 32bit windows application written in Delphi.

-- 
Prisma Computer GmbH
Sternallee 89  -  68723 Schwetzingen
Fon 0 62 02.5 75 68 10
Fax 0 62 02.5 75 68 75
eMail:[email-masked]
Internet:www.prisma-computer.de

Geschäftsführung: Gerald Wilkens, Bernhard Goebel
Amtsgericht Mannheim HRB 420986 S
USt-IdNr.: DE 144 278 153

---

From: "Wal, Jan Tjalling van der" <[email-masked]>
Date: Thu, 12 Oct 2023 19:25:25 +0000

Yes also at my place of work.
Access front-end(s) links to Postgresql via ODBC. For several colleagues the Office is still 32-bits, so requires 32-bits DLL.

Kind regards, Jan Tjalling

Sent from Outlook for Android<https://aka.ms/AAb9ysg>
________________________________
From: Jon Raiford <[email-masked]>
Sent: Thursday, October 12, 2023 5:35:07 PM
To: Dave Cramer <[email-masked]>; PostgreSQL mailing lists <[email-masked]>
Subject: Re: 32 bit DLL's

Jon

Is anyone using them?

Dave Cramer

---

From: Brad White <[email-masked]>
Date: Thu, 12 Oct 2023 16:28:16 -0500

Continuing with the top posting so as not to confuse things.

Same here. Our whole office runs on a 32-bit Access app connected via 
ODBC to Postgres 15.

Thanks,
Brad.

On 10/12/2023 2:25 PM, Wal, Jan Tjalling van der wrote:
> Access front-end(s) links to Postgresql via ODBC. For several 
> colleagues the Office is still 32-bits, so requires 32-bits DLL.
>
> Sent from Outlook for Android <https://aka.ms/AAb9ysg>
> ------------------------------------------------------------------------
> *From:* Jon Raiford <[email-masked]>
> *Sent:* Thursday, October 12, 2023 5:35:07 PM
> *To:* Dave Cramer <[email-masked]>; PostgreSQL mailing lists 
> <[email-masked]>
> *Subject:* Re: 32 bit DLL's
>
> *From: *Dave Cramer <[email-masked]>
> *Date: *Thursday, October 12, 2023 at 9:26 AM
> *To: *PostgreSQL mailing lists <[email-masked]>
> *Subject: *32 bit DLL's
>
-- 
Quote Signature I talk with clients, find out where their pain points 
are, and solve those.
On-call IT Management for small companies and non-profits.
SCP, Inc.
[email-masked]
402-601-7990

Quote of the Day
    There is a huge difference between fathering a child and being a 
father.
    One produces a child. The other produces an adult.
     -- John Eldredge

---

From: Pierre Couderc <[email-masked]>
Date: Fri, 13 Oct 2023 09:58:41 +0200

> I noticed that the project currently provides 32bit DLL's in the release.

Absolutely !

We have migrated a big old ODBC 32 bits project from Access/SQL Server 
to ODBC32bits  Postgresql because of stability of Postgresql.  Many 
32bits projects developed in 90's continue to be used and run on modern 
computers...

We maintain old VC6 32bits projects (MS FORTRAN+MS VC6+ODBC) using an XP 
VM on modern (linux...) computer. And the .exe resulting  of these 
projects run on W10/W11 computers with  modern Posgresql...

Independence of MS is strategic !

Pierre Couderc

---

From: Dave Cramer <[email-masked]>
Date: Fri, 13 Oct 2023 05:45:06 -0400

Dave Cramer
www.postgres.rocks

On Fri, 13 Oct 2023 at 03:59, Pierre Couderc <[email-masked]> wrote:

> We have migrated a big old ODBC 32 bits project from Access/SQL Server to
> ODBC32bits  Postgresql because of stability of Postgresql.  Many 32bits
> projects developed in 90's continue to be used and run on modern
> computers...
>
> VM on modern (linux...) computer. And the .exe resulting  of these projects
> run on W10/W11 computers with  modern Posgresql...
>

OK, I think I have the message :)

Thanks

Dave

---

From: Dave Cramer <[email-masked]>
Date: Fri, 13 Oct 2023 05:55:50 -0400

> OK, I think I have the message :)

Building PostgreSQL on 32bits in order to get libpq dll's seems to be
challenging. If anyone has some experience doing this, let me know.

Also I plan on moving development to github postgresql-interfaces/psqlodbc
(github.com) <https://github.com/postgresql-interfaces/psqlodbc>

<https://github.com/postgresql-interfaces/psqlodbc>Dave

---

From: Pierre Couderc <[email-masked]>
Date: Fri, 13 Oct 2023 12:14:50 +0200

Le 10/13/23 à 11:55, Dave Cramer a écrit :
>         We have migrated a big old ODBC 32 bits project from
>         Access/SQL Server to ODBC32bits  Postgresql because of
>         stability of Postgresql.  Many 32bits projects developed in
>         90's continue to be used and run on modern computers...
>
>         We maintain old VC6 32bits projects (MS FORTRAN+MS VC6+ODBC)
>         using an XP VM on modern (linux...) computer. And the .exe
>         resulting  of these projects run on W10/W11 computers with
>         modern Posgresql...
>
> Also I plan on moving development to github 
> postgresql-interfaces/psqlodbc (github.com) 
> <https://github.com/postgresql-interfaces/psqlodbc>
>
> Dave

Mmm, sorry I know nothing of "building 32 bits dll" but the only point 
is to keep PSQLODBC30A.DLL ans PSQLODBC35W.DLL as they are now.

Moreover, I do not think useful (for me!!) to add modern new features of 
last Postgesql to the ODBC 32bits interface, that is "maintain" but not 
necessarily "improve"...

PC