Subject: encryption of password

From: Oliver Spickhoff <[email-masked]>
Date: Tue, 7 Feb 2023 14:08:10 +0000

Hi,

I have a suggestion for an enhancement:
When you click SAVE the password is stored as clear text in HKEY_CURRENT_USER\Software\ODBC\ODBC.INI\postgres\Password

Would it be possible to store the password encrypted?

Thanks,
Oliver

Oliver Spickhoff
Geschäftsführer • Managing Director

OSYON GmbH • Pfuelstraße 5 • 10997 Berlin • Germany
fon +49 30 310135-0 • fax +49 30 310135-55
[email-masked]<mailto:[email-masked]> • www.osyon.com<http://www.osyon.com>

[OSYON GmbH]

Reg-Nr: HRB 82465 AG Charlottenburg • USt-ID: DE217618646 • Geschäftsführer: Oliver Spickhoff

---

From: Benjamin Pochat <[email-masked]>
Date: Wed, 20 Nov 2024 15:08:29 +0100

Hi,

I was looking for the same feature.

In my company, the use of postgre odbc client is compromised because
passwords are stored as clear text in Windows registry.
Our use case consists in individual authentication to postgre databases,
thanks to ldap2pg tool, for BI purposes.
As a consequence, individual passwords are used in odbc clients.
Then, the fact that postgre odbc client stores these passwords as clear
text is a real security issue.

Password encryption would be really appreciated.

Regards,

Benjamin

Le mer. 20 nov. 2024 à 14:58, Oliver Spickhoff <[email-masked]>
a écrit :

> When you click SAVE the password is stored as clear text in
> HKEY_CURRENT_USER\Software\ODBC\ODBC.INI\postgres\Password
>
>
>
> [email-masked] • www.osyon.com
>
>

---

From: Dave Cramer <[email-masked]>
Date: Wed, 20 Nov 2024 11:26:05 -0500

Please post this on github https://github.com/postgresql-interfaces/psqlodbc
Dave Cramer
www.postgres.rocks

---

From: Benjamin POCHAT <[email-masked]>
Date: Thu, 21 Nov 2024 08:28:18 +0100

Ok

This issue has been open in GitHub : 
https://github.com/postgresql-interfaces/psqlodbc/issues/74

On 20/11/2024 17:26, Dave Cramer wrote:
> Please post this on github 
> https://github.com/postgresql-interfaces/psqlodbc
> Dave Cramer
> www.postgres.rocks
>
>
> On Wed, 20 Nov 2024 at 09:18, Benjamin Pochat 
> <[email-masked]> wrote:
>
>     Hi,
>
>     In my company, the use of postgre odbc client is compromised
>     because passwords are stored as clear text in Windows registry.
>     Our use case consists in individual authentication to postgre
>     databases, thanks to ldap2pg tool, for BI purposes.
>     Then, the fact that postgre odbc client stores these passwords as
>     clear text is a real security issue.
>
>     Le mer. 20 nov. 2024 à 14:58, Oliver Spickhoff
>     <[email-masked]> a écrit :
>
>         Hi,
>
>         [email-masked]• www.osyon.com <http://www.osyon.com>
>
>         OSYON GmbH
>