Subject: “FATAL: role “username” does not exist”. Thanks.

From: "Matt Russo (mrusso)" <[email-masked]>
Date: Fri, 23 Jul 2021 16:06:31 +0000

Hi,

   I installed the Postgresql ODBC drivers and when I try to test my connection I get “FATAL: role “postgres” does not exist”.
I am able to connect to PostgreSQL and use it in pgAdmin.
I tried adding a role for the user but PG returns it already exists.
I also added a role of a different user PGADMIN but that gave the same error.

I fully uninstalled PostgreSQL.  Deleted the directory postgresql in program files.
Fully uninstalled the ODBC drivers.
I installed PostgreSQL 13.
I installed the 13 ODBC drivers.
I am still getting the same error.
No bugs listed like this on https://www.postgresql.org/list/pgsql-bugs/
Dr. Google suggests a role or username is lacking.  So I try adding a role but it says user postgres already exists.
I tried adding a second user.  No good trying the second user.

Please let me know your advice.

Best Regards,

Matt

Matt Russo | Enterprise Technical Support Senior Advanced
P: 813-600-3438 E: [email-masked]<mailto:[email-masked]> erwin by Quest

---

From: Clemens Ladisch <[email-masked]>
Date: Sat, 24 Jul 2021 14:53:01 +0200

On 23.07.2021 18:06, Matt Russo (mrusso) wrote:
 >     I installed the Postgresql ODBC drivers and when I try to test my
 > connection I get “FATAL: role “postgres” does not exist”.

What does the database's log file show at this time?

Regards,
Clemens