Subject: ODBC Driver for PostgreSQL

From: "Torres Cervantes, Salvador" <[email-masked]>
Date: Thu, 27 Oct 2022 14:47:25 +0000

Hello,
I'm trying to use your drivers. But I have the following error message. Could you please help ? any idea why ?

Regards,

Salvador T.

---

From: Heikki Linnakangas <[email-masked]>
Date: Thu, 27 Oct 2022 17:18:25 +0200

>I'm trying to use your drivers. But I have the following error message. Could you please help ? any idea why ?

"authentication method 10 not supported" means that the server is configured to use SCRAM authentication, and the driver is an old version that doesn't support it. Upgrade the ODBC driver.

- Heikki

---

From: "Torres Cervantes, Salvador" <[email-masked]>
Date: Thu, 27 Oct 2022 15:25:17 +0000

Which driver do you recommend to use ?

This is the one I'm using.

Thx,

-----Original Message-----
From: Heikki Linnakangas <[email-masked]>
Sent: Thursday, October 27, 2022 8:18 AM
To: [email-masked]; Torres Cervantes, Salvador <[email-masked]>; [email-masked]
Subject: Re: ODBC Driver for PostgreSQL

CAUTION: External Email

- Heikki

---

From: "Torres Cervantes, Salvador" <[email-masked]>
Date: Thu, 27 Oct 2022 15:28:02 +0000

Is Version 13 ok ?

From: Torres Cervantes, Salvador
Sent: Thursday, October 27, 2022 8:25 AM
To: Heikki Linnakangas <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: ODBC Driver for PostgreSQL

Thx,

-----Original Message-----
From: Heikki Linnakangas <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, October 27, 2022 8:18 AM
To: [email-masked]<mailto:[email-masked]>; Torres Cervantes, Salvador <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: ODBC Driver for PostgreSQL

CAUTION: External Email

- Heikki

---

From: "Torres Cervantes, Salvador" <[email-masked]>
Date: Thu, 27 Oct 2022 15:51:07 +0000

OK.

I was able to install new Driver and Connection Successful but still have an error when creating the LINK Server on SQL

Thx,

Salvador T.

-----Original Message-----
From: Heikki Linnakangas <[email-masked]>
Sent: Thursday, October 27, 2022 8:18 AM
To: [email-masked]; Torres Cervantes, Salvador <[email-masked]>; [email-masked]
Subject: Re: ODBC Driver for PostgreSQL

CAUTION: External Email

- Heikki

---

From: "Regina Obe" <[email-masked]>
Date: Tue, 1 Nov 2022 12:27:29 -0400

I can’t tell from your screenshot if you have registered a file dsn, user dsn, or system dsn.

To work in SQL Server, I think it has to be a System DSN.  Also make sure you are using the 64-bit ODBC Manager and not the 32-bit one.  Note the top of the dialog should say “64-bit” and your entry should be in the System DSN section

From: Torres Cervantes, Salvador [mailto:[email-masked]] 
Sent: Thursday, October 27, 2022 11:51 AM
To: Heikki Linnakangas <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: ODBC Driver for PostgreSQL

OK. 

 

Thx,

Salvador T.

-----Original Message-----
From: Heikki Linnakangas <[email-masked] <mailto:[email-masked]> > 
Sent: Thursday, October 27, 2022 8:18 AM
To: [email-masked] <mailto:[email-masked]> ; Torres Cervantes, Salvador <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: ODBC Driver for PostgreSQL

CAUTION: External Email

- Heikki

---

From: Pierre Couderc <[email-masked]>
Date: Wed, 2 Nov 2022 06:51:25 +0100

On 10/27/22 17:51, Torres Cervantes, Salvador wrote:
>
> OK.
>
> I was able to install new Driver and Connection Successful but still 
> have an error when creating the LINK Server on SQL
>
> Thx,
>
> Salvador T.
>
> To: [email-masked]; Torres Cervantes, Salvador 
> <[email-masked]>; [email-masked]
> On 27 October 2022 16:47:25 CEST, "Torres Cervantes, Salvador" 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> >Hello,
>
> >I'm trying to use your drivers. But I have the following error 
> message. Could you please help ? any idea why ?
>
> "authentication method 10 not supported" means that the server is 
> configured to use SCRAM authentication, and the driver is an old 
> version that doesn't support it. Upgrade the ODBC driver.
>
> - Heikki
>
I do not know what you are trying to do with  SQL Server Management 
Studio (SSMS), but forget it ! This tool is only for MS products...

You cannot use it to test PostgreSQL...

---

From: Pierre Couderc <[email-masked]>
Date: Wed, 2 Nov 2022 06:59:49 +0100

> You cannot use it to test PostgreSQL...
Moreover, your connection is successful, I do not think you need 
anything more such as "creating the LINK Server on SQL"(???)....

Just start using it !

---

From: David Parenteau <[email-masked]>
Date: Wed, 2 Nov 2022 12:42:32 +0000

You have to take care to use “ODBC 32-bit” OR “ODBC 64-bit “ to create your ODBC. Systems allow you to create these 2 types. SQL Server probably use the 64bit but I would suggest to also test with a 32 bit ODBC…

From: Pierre Couderc <[email-masked]>
Sent: November 2, 2022 2:00 AM
To: [email-masked]
Subject: Re: ODBC Driver for PostgreSQL

OK.

Thx,

Salvador T.

-----Original Message-----
From: Heikki Linnakangas <[email-masked]><mailto:[email-masked]>
Sent: Thursday, October 27, 2022 8:18 AM
To: [email-masked]<mailto:[email-masked]>; Torres Cervantes, Salvador <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: ODBC Driver for PostgreSQL

CAUTION: External Email

- Heikki

I do not know what you are trying to do with  SQL Server Management Studio (SSMS), but forget it ! This tool is only for MS products...

Moreover, your connection is successful, I do not think you need anything more such as "creating the LINK Server on SQL"(???)....

Just start using it !

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

---

From: Pierre Couderc <[email-masked]>
Date: Wed, 2 Nov 2022 15:33:20 +0100

On 11/2/22 13:42, David Parenteau wrote:
>
> You have to take care to use “ODBC 32-bit” OR “ODBC 64-bit “ to create 
> your ODBC. Systems allow you to create these 2 types. SQL Server 
> probably use the 64bit but I would suggest to also test with a 32 bit 
> ODBC…
>
Mmm, the point is not "SQL server"... Certainly, there is no "SQL 
Server" at all !!!.

The point is 32bits application or 64bits application...

---

From: David Parenteau <[email-masked]>
Date: Wed, 2 Nov 2022 14:37:25 +0000

I meant, when you create your Linked Server and specify the ODBC Name you just created, maybe you should specify a 64-bit ODBC name… But if you created yours using the 32-bit application, then it’s normal that process cannot find it. Make sure you have a 32bit and a 64bit ODBC so this way, you make sure ODBC exists under both versions.

HTH.

From: Pierre Couderc <[email-masked]>
Sent: November 2, 2022 10:33 AM
To: [email-masked]
Subject: Re: ODBC Driver for PostgreSQL

Mmm, the point is not "SQL server"... Certainly, there is no "SQL Server" at all !!!.

---

From: "Torres Cervantes, Salvador" <[email-masked]>
Date: Thu, 3 Nov 2022 17:56:37 +0000

Hi Regina,
I have created under System DSN. Let me test again.

Thx,
Salvador T.

From: Regina Obe <[email-masked]>
Sent: Tuesday, November 1, 2022 9:27 AM
To: Torres Cervantes, Salvador <[email-masked]>; 'Heikki Linnakangas' <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: ODBC Driver for PostgreSQL

CAUTION: External Email

From: Torres Cervantes, Salvador [mailto:[email-masked]]
Sent: Thursday, October 27, 2022 11:51 AM
To: Heikki Linnakangas <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: ODBC Driver for PostgreSQL

OK.

Thx,

Salvador T.

-----Original Message-----
From: Heikki Linnakangas <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, October 27, 2022 8:18 AM
To: [email-masked]<mailto:[email-masked]>; Torres Cervantes, Salvador <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: ODBC Driver for PostgreSQL

CAUTION: External Email

- Heikki