Subject: Supported PG versions

From: Jan-Willem Goossens <[email-masked]>
Date: Wed, 1 Dec 2021 09:44:02 +0000

Hi,
Is there a table that explains which versions of the PostgreSQL database are supported by a particular version of psqlODBC?
For example, is PG 10 officially supported by psqlODBC 13.02?
I tried to find this info in release notes, FAQ, etc. but no luck. Apologies if I did not look hard enough.

Thanks for your help,
Jan-Willem

---

From: Jan-Willem Goossens <[email-masked]>
Date: Wed, 1 Dec 2021 10:29:44 +0000

Searching in the archives here, I now found
https://www.postgresql.org/message-id/CAOfVbsoiJwf2dP2VGaMVWM_CrMwEq10C=[email-masked]
“just use the latest driver. It works with all (supported) server versions.”

At the time of writing, PG 10 is still supported according to the Versioning Policy, so I presume the answer to my example is Yes for the latest release psqlODBC 13.02?

However, since the supported server versions change over time, would it not be good to include one line in the Release notes of psqlODBC that explicitly lists the supported server engine major versions?

Jan-Willem

From: Jan-Willem Goossens<mailto:[email-masked]>
Sent: Wednesday, 1 December 2021 10:44
To: [email-masked]<mailto:[email-masked]>
Subject: Supported PG versions

Hi,

Thanks for your help,
Jan-Willem