Subject: ODBC configuration problem

From: Steven Adams <[email-masked]>
Date: Mon, 18 Nov 2024 22:27:42 +0000

Hello,

I'm trying to use MS Access with PostgreSQL and so want to configure an ODBC file for this.  Testing it resulted in a connection timeout, so I looked at this to troubleshoot:
https://odbc.postgresql.org/faq.html#3.3
Adding a "tcpip=true" line to postgresql.conf and a line to permit a connection from the computer running Access to pg_hba.conf and then restarting PostgreSQL seemed to go without errors, but when I tried to run the psql command afterward, I got this error:
psql: error: connection to server at "localhost" (127.0.0.1), port 5432 failed: Connection refused
        Is the server running on that host and accepting TCP/IP connections?

The psql command worked again after I undid these changes, so I'm trying to figure out how they caused this error.  The line I added to pg_hba.conf was as follows.
host      spiralxprime     web_app     192.168.0.72     scram-sha-256

Any ideas as to why this is happening would be appreciated.

Regards,

Steven Adams

---

From: Dave Cramer <[email-masked]>
Date: Mon, 18 Nov 2024 17:33:19 -0500

I'd prefer if this were on github
https://github.com/postgresql-interfaces/psqlodbc/issues

But my guess is that your postgresql.conf file does not have localhost
enabled.
https://www.postgresql.org/docs/current/runtime-config-connection.html#GUC-LISTEN-ADDRESSES
Dave Cramer
www.postgres.rocks

On Mon, 18 Nov 2024 at 17:28, Steven Adams <[email-masked]>
wrote:

> Hello,
>
> I'm trying to use MS Access with PostgreSQL and so want to configure an
> ODBC file for this.  Testing it resulted in a connection timeout, so I
> looked at this to troubleshoot:
> Adding a "tcpip=true" line to postgresql.conf and a line to permit a
> connection from the computer running Access to pg_hba.conf and then
> restarting PostgreSQL seemed to go without errors, but when I tried to run
> the psql command afterward, I got this error:
> The psql command worked again after I undid these changes, so I'm trying
> to figure out how they caused this error.  The line I added to pg_hba.conf
> was as follows.

---

From: Steven Adams <[email-masked]>
Date: Tue, 19 Nov 2024 02:06:32 +0000

Okay, I posted about it on Github.
________________________________
From: Steven Adams <[email-masked]>
Sent: Monday, November 18, 2024 4:27 PM
To: [email-masked] <[email-masked]>
Subject: ODBC configuration problem

Hello,

Regards,

Steven Adams